Errors when adding buttons in Rasa Forms


I’ve attempted to add buttons to a form with zero luck, here is some snippets in my docs. I’ve tried ignoring everything else and just getting one form to work with buttons so ignore everything besides student_profile. I’ve tried adding more NLU data, but also no luck there.

I’ve also tried doing mapping of buttons with value: entity, but get “Failed to fill utterance template ‘/student_inform{“Education_level”: “Less than high school”}’. Tried to replace ‘“Education_level”: “Less than high school”’ but could not find a value for it. There is no slot with this name nor did you pass the value explicitly when calling the template. Return template without filling the template.” It allows me to select a button but immediately expects input from user

Domain File: Focus on intents: less_than_hs and hs_equivalent Entity: education_level listed & utterance is listed under actions section image image image


config: (I know FormPolicy will be deprecated in Rasa 3.0 but this project is due next week for me) image



stories: image

1 Like

It would be a great help if someone from @Staff-Badge would help in this query.

1 Like

Were you able to get this to work properly yet?

I have some time so I can fire up a Rasa 2.0 bot to try to figure this out for you.

unless you have your code in a git repo I can pull down and debug