Please help with RASA Button

Hi,

I tried to use Buttons in Rasa shell. After reading the Rasa docs, I tried this

Rules File:

- rule: What help can it provide
  steps:
  - intent: whathelp
  - action: utter_whathelp

Domain File:

utter_whathelp:
  - text: "I can assist with below"
    buttons:
    - title: "Plant Protection"
      payload: "/utter_ask_pp"
    - title: "Nutrient Management"
      payload: "/utter_ask_nm"
    - title: "Agri Officers contact"
      paylod: "/utter_ask_agricontact"

I’ve also added those utter response in domain.

  utter_ask_pp:
  - text: "Could you please give the crop name and disease?"
  utter_ask_nm:
  - text: "Could you please give the crop and their deficiency?"
  utter_ask_agricontact:
  - text: "Could you please give Agri officer's desg and ditrict name?"

But when I execute the Button and select the respective buttion, I get a value error for “utter_ask_pp”, though it has been added to domain file.

Please advise on how to fix this.

You need to put those in intents

payload: “/utter_ask_pp”, this will be intent “utter_ask_pp” and then you need to make a story, where you have a rule that when you have intent “utter_ask_pp” then you do action “utter_ask_pp”

1 Like

@InnoOmnia Thank you for the information! Will try now and update the outcome.

@InnoOmnia Thank you! Now it is working fine!!

1 Like