Annotate new data error

(Julien P) #1
  1. Recently the section of the NLU Training started acting strange in Rasa X. I press the plus to add a new sentence. The error is when I start writing a new sentence to add to the training data. After the first letter the enter button greys out and won’t interact. Giving no more feedback after that. I’ve stopped the server and started it again. Tried three different browsers. The console is not throwing any errors that I can see and the rasa_core.log is empty.

  2. Also I have been wondering the steps necessary to make sure that buttons appear as choices to guide the conversation for my users. I’ve tried editing the domain file as per the instructions in the Rasa X docs but I can’t see any buttons in Rasa X.

Thank you!

(Julien P) #2

I discovered that by deleting the rasa.db and tracker.db files from my local rasa folder, I can get functionality back from the above error. Probably due to some kind of database format error that gets corrected when rasa x recreates new rasa.db and tracker.db files.

(Akela Drissner) #3

Hmm that’s odd, let me know if you encounter this again!