Connection to Gitlab Repository is failing

Hi, I am trying to connect to my GitLab repository for a while. I am repeatedly getting the same error and can’t make any progress.

code: 422
details: "Given repository credentials don't provide write permissions to the repository. Please make sure the SSH key is correct and the administrator of the remote repository gave you the required permissions."
help: null
message: "Insufficient permissions for remote repository."
reason: "RepositoryCreationFailed"
status: "failure"
version: "0.41.1"

I tried everything from hitting Rasa API by manually generating the SSH keys and also adding in the Rasa X UI directly. I have checked all the suggested solutions and/or requirements mentioned in the forum for the same issue. But none of them has worked for me. The checklist for solutions tried-

  1. My GitLab repository has the correct directory structure. I am using the SSH url and also the mentioned branch exists in my repo
  2. Have added the SSH key in the Deploy Keys section in Repository with write access enabled
  3. When manually generating SSH keys, I did not set any password and hit the Rasa API with the correct api_token found in the Rasa X UI model’s section.

Rasa Version: 2.7.1-full
Rasa-X Version: 0.41.1

Please suggest if you have any other debugging tips.


Take a look at the Rasa X log (make sure you have debug on) during the time that you try the connection to the repo. You may get more details about the error.

From within the Rasa X container, try pulling the repo in a separate directory, create a branch and try and push the branch. All using the SSH key that Rasa X generated.