Rasa Interactive for Version Controll

I am trying to use the version control for my rasa-x ui. I have completed all steps but at last during verification. I am getting error

I am using this command: sudo curl --request POST --url http://XX.XXX.X.XXX/api/projects/default/git_repositories?api_token=**************************************** –header ‘content-type: application/json’ --data-binary @repository.json

I am getting this error: {“version”:“0.25.2”,“status”:“failure”,“message”:“Insufficient permissions for remote repository.”,“reason”:“RepositoryCreationFailed”, “details”:{“args”:[“Given repository credentials don’t provide write permissions to the repository. Please make sure the ssh key is correct and the administrator of the remote repository gave you the required permissions.”]},“help”:null,“code”:422}

Please help me out from this error. Thanks in advance

You probably didn’t click the Allow write access box when you added your ssh key to the repo.

Thanks for your reply stephens,

I have confirmed once again and found that I have already clicked on allow write access. But still getting error is same. So I have updated my rasa-x version 0.28.

Now I have got this window and don’t know where to put this key?

I have a public key which I have already put in my github as deploy key. One more I have a private key which I have put in my “repository.json” file. Then where should I put this key.

please explain me step by step clearly.


You should not be using your own public key. Rasa X generates the key you’ve shown in that screenshot. You need to paste that key into the github settings deploy key and make sure you allow write access.

Hello stephens,

I have paste that key into my github settings and also allow write access. But it is showing something went wrong message. Please try again…

So, what I can do now.

Look at the Rasa X log. If you’re running under docker-compose use:

docker-compose logs rasa-x

I’m with the same issue, someone found the solution?