Integrated Version Control issue: Gitlab

Hi all, I’m using gitlab, and im receiving the following write permission error

curl --request POST \
     --url http://<myapi>/api/projects/default/git_repositories?api_token=<token> \
     --header 'content-type: application/json' \
     --data-binary @repository.json

with the repository.json

{
    "repository_url": "git@gitlab.playcourt.id:31022/missindi/rasax.git",
    "ssh_key": "-----BEGIN RSA PRIVATE KEY-----
<private_key>
-----END RSA PRIVATE KEY-----",
    "target_branch": "master"
}

but i got respon

{"version":"0.24.6","status":"failure","message":"Insufficient permissions for remote repository.","reason":"RepositoryCreationFailed","details":{"args":["Given repository credentials don't provide write permissions to the repository. Please make sure the ssh key is correct and the administrator of the remote repository gave you the required permissions."]},"help":null,"code":422}

I don’t have a clue what’s going wrong, and really like to get this to work. thankyou

Hi @desims, have you uploaded the public key to your gitlab?

Thanks @mloubser

I have upload public key to my gitlab project. i follow tutorial from juste in youtube channel YouTube

Hello, I have exactly the same issues and I have been struggling for it for days now… I’m following this thread !

@desims @LucieTronelle when configuring the key, was there a place to give that key write access? Or if you Edit it can you then?

Hello Every one i m using the Rasa Masterclass video YouTube to setup rasa x.

Currently i m facing following issue :

How to solve this.

Long ago when video was uploaded, i somehow solved it but dont remember the steps to do it.

The error it return is curl: (7) Failed to connect to 34.67.103.187 port 443: Connection refused.

I have created and edited correctly repository.json as shown below:

correctly copied and pasted the ssh-key into the github repo of mine :

What should i do?

Did it solved.

Just remember to do this :

curl --request POST
–url http:///api/projects/default/git_repositories?api_token=
–header ‘content-type: application/json’
–data-binary @repository.json

instead of

curl --request POST
–url https:///api/projects/default/git_repositories?api_token=
–header ‘content-type: application/json’
–data-binary @repository.json

Since as we have to change from https to http.

You may close my issue.

I have the same problem with @desims and @LucieTronelle. I’m sure that I have the permission because i made the key with sudo command. So yeah I can Edit the file. Idk what’s error now, I’ve struggled on it for almost two weeks :’(

Hoping on your respond, thanks

Sorry @paraparata, i should clarify, the question wasn’t whether you had write permissions to edit the actual file, but rather whether your deploy key has write permission for the repository.

Can you first try with the newest Rasa X (0.26.0) which makes the process a little easier by only giving you a public key to copy, and nothing to create on your own/upload via an endpoint?