Second bot response is empty

Hi, I just finished setting up rasa with docker. I ran docker-compose up and everything is fine. Now i used the curl command to sent a message “Hello” just like in the docs

and i get the right response, but the thing that’s happening is when i run the very same command again, it returns []. I also used postman and the same thing happened. I noticed that everytime i send a message and i change the “sender” parameter to something else, then i get another response. f.e. i send a post request to http://localhost:5005/webhooks/rest/webhook with data

{ “sender”: 1, “message”: “hello” }

i get the correct response, but i will always get an empty response until i change that sender parameter. Is that really an expected behavior? How do i have a conversation with the bot if it won’t sent a second message to the same sender?

PS. Gotta stress out that i’m 2 days into Docker and 3 days into Rasa, so very new, very noob, so sorry if this question is stupid or very simple and obvious.

Seems like your trained model cannot handle the other messages. How do your stories look like?