Bot not answering on Telegram

Hi guys,

I installed and tryed the starter-pack-rasa-stack project. Everything looks working properly, and I can talk to the chat in the command line as described in the tutorial.

The problem is that when I try to make it communicate with telegram or slack I receive no answer.

In the command line it prints everytime that I write to the bot in telegrem so it looks like that it receive the messages but then there is no answer in telegram: 2018-12-03 12:54:19 INFO rasa_core.channels.telegram - Webhook Setup Successful 2018-12-03 12:54:19 INFO root - Rasa Core server is up and running on http://localhost:5002 - - [2018-12-03 12:54:22] “POST /webhooks/telegram/webhook HTTP/1.1” 200 121 0.082027

Steps that I followed: -All steps of and I am able to run the bot and talk to it in the command line

-Run ngrok

-Run actions end point

-Run command “python -m -d models/current/dialogue -u models/current/nlu --endpoints endpoints.yml --port 5002 --credentials telegram_credentials.yml”

In the telegram_credentials file (as written in the web site) there is: telegram:

access_token: “582942230:AA…”

verify: “-name of the bot-”

webhook_url: “-ngrok address-/webhooks/telegram/webhook”

What am I doing wrong ? I also tried with slack (everything set up in lsack) and with other rasa project but I always have the same problem the bot do no answer me .

I was missing some dependecies. SOLVED

Can you elaborate?

I have the same issue. I’ve upgraded core and nlu, freshly training model and dialogue, ngrok running, telegram credentials are good, when I type a telegram hello I have 200 success responses is ngrok terminal and rasa core server terminal, but no actual conversation is returned.