Issue integrating Rasa and Telegram!

Hi, I have an issue with integrating Rasa with Telegram.

I have followed almost every resource I can find, however I cannot get any response from my bot in Telegram.

In my credentials file, I follow the exact instructions from the Rasa documentation;

As a test, I used ngrok to share my rasa x globally according to this video : Share Rasa Chatbot for Production - YouTube I have used ngrok https 5002 to share my assistant globally, where I notice http requests on ngrok are active with multiple get requests etc, and the bot replies.

However when I try and use ngrok http 5005 to share my bot with Telegram, there seems to be no connection between Rasa and telegram and no Http requests (get requests)?

Can you please advise any steps I can take to rectify this and attempt to connect Rasa and Telegram? Apologies I am quite new to Rasa so I’m not sure what code you will need to see in order to diagnose?

Hi! :smiley:

Are you using https ngrok link? put /webhooks/telegram/webhook ? and start using --enable-api --cors "*" ?

Reference: Integrate Rasa With Telegram Chatbot - YouTube

Hi Joāo,

Thanks for the quick reply.

I can confirm that I am using the https ngrok link before /webhooks/telegram/webhook.

I’ve tried using rasa run --enable-api --cors "*", to start the rasa server on localhost 5005 also.

My telegram is still not replying, for whatever reason it seems as if telegram is not connecting to 5005 localhost on ngrok. When I paste the ngrok url into my browser it says Hello From Rasa {version no.} however there is no reply when I talk to the bot on telegram. As you can see below there are no connections or HTTPS get requests which I assume would appear once I talk to my bot on telegram.

Would you know of any others way’s to try and diagnose the issue?

Thank you.

I think has not another way

But… i think it’s happen because some miss configuration Did you type /newbot and put same access_token and username Bot Father return to you?

Hi Joāo,

I feel like an idiot, i had accidentally inputted another space between telegram under rest therefore it was not picked up. Something so simple yet I overlooked it. :sweat_smile: :sweat_smile:

Your comment however made me look back over it and find my error, so thank you for your help!! :hugs:

Have a great day!

1 Like

:joy: :joy: :joy:

It’s happen

Thank you!

Have a great day too!