Slack Bot does not respond

I am trying out the slack integration part of the updated weatherbot tutorial, and I can’t manage to get the bot to respond to my inputs on Slack. As I enter something in the slack textbox, I see a 200 code on my console, as well as on my and ngork console. I have enabled app_mention and events on the Slack API’s event subscription page, and I am unsure so as to why I am not getting a response. Can someone please help me figure out how to fix this ? Here I have added screenshots of the ngork terminal, as well as the run_app code snippet and terminal output. Also included are screenshots of app permissions on Slack


edit: I added some screenshots to better describe the problem. The last screenshot is the output of the command on the terminal using the debug flag. It seems like the issue is with posting the correctly inferred response to slack. I have double checked my bot user OAuth access token in the slack_credentials/ file as well as revisited all the bot settings, but I still get the same exception everytime.

update :- after going through the debug logs, it appears that the issue is with the slackclient connector , although I have no idea how to correct it. I have tried downgrading websocket_client to version 0.47.0, as well as downloading DigiCert certificate and exporting WEBSOCKET_CLIENT_CA_BUNDLE, but nothing works.

Hi @enginoir! I recommend using the latest version of Rasa called Rasa 1.0. It combined Core and NLU into one repo called Rasa, has a vastly simplified CLI, and will be much easier to get help when you run into problems like this (many bugs have been fixed since this version). I followed the getting started page and the Rasa Tutorial this past week and was able to get my slackbot up and running quickly without any issues. You can always use the data from the tutorial if you are interested in making that weatherbot. I can definitely help you, if you do that.

If you don’t want to upgrade, I suspect that your issue with the slack connector might actually be an issue with your action server, where slack is giving you an error because an action is broken and then a timeout occurs. Let me know if you would like to go this route, share your action server code, and I’ll take a look

Thanks @tyd for helping me with this. I am enclosing screenshots of my code and server terminal

As you can see, I am seeing a response from the action server, but then , because of the tls_process_server_certificate verify fail, it doesn’t get posted to the Slack Channel .

I managed to get the thing working. As it turns out , the issue was with the python request library. I had to modify the request function in the file to disable certificate check. Thanks all!


Awesome. Glad you were able to get it working. I really recommend upgrading to Rasa 1.0, so you can avoid bugs like this and use Rasa X. It is really cool and well be really helpful once you want to take this bot to the next level!

hello sir even i am facing the same issue while deploying our chatbot with slack.connection established successfully but we are not getting the desired output. can you please solve our problem? Thanks in advance.