500 Error from Production

I’ve followed the Deploy to Server setup (docker) for Rasa X and successfully created a model from imported training data. I’m getting a server error when using the Talk to your Bot page.

I run the version call against Rasa X and the output shows:

    "rasa": {
        "production": "1.1.7",
        "development": {
            "status": 500,
            "message": null
        "worker": "1.1.7"
    "rasa-x": "0.20.0"

Should I have a development instance of Rasa running after following the Deploy to Server instructions?

When I go to the Models screen, it allows me to activate a model but there’s no choice of production or development, probably because development is not running. I choose Make Active on the model.

Then, go to the Talk to your bot and enter a question to the production bot. The network tab of the browser shows I’m getting an error 500 against the following URL.


Any suggestions on next steps.

There are 2 versions of Rasa, 1 is CE (Community Edition) and one is Enterprise, I remember installing from server there was a step to be sure your using CE edition. I believe the choice for Prod vs Dev is only in the Enterprise edition, community just gives you 1 to use. So if you trained a model it should autoload your model as prod.

Something might be funny with your imported data too, can you look at your data in Rasa X? ie stories etc?

Thanks for the clarification. Yes, I’m using the CE version which only has the one instance.

I’ve reviewed my data and did some clean-up based on warnings on the Domain screen and an error that occurred during Training. My training now runs without errors and produces a model which I can activate.

1 Like


I have also installed rasa with the regular command and -nohup the Rasa X on a digital ocean server, used MobaX to transfer files over. I am new to a lot of this, but found it easy to drag story files etc, over, I have built a few bots comprised of different sample bots, and easily updated all my files that way

Unfortunately, it’s still not working. I have a second CE running that works fine. Not sure yet what the difference in the two instances.

What size DO droplet are you using?

I was running an 8GB, 40/month I think? I forget

I build and destroy, I think its the min that they recommend