Unexpected error when running `rasa interactive` and marking entities


When running rasa interactive everything goes gently until I want to create a new intent. Rasa asks me then if there are any entities in my sentence, this there is no entities I press Enter, then the following error displays:

What intent is it? <create_new_intent>
Please type the intent name: askBot
Please mark the entities using value notation What’s your name
2021-08-18 16:27:17 ERROR rasa.server - An unexpected error occurred. Error: ‘askBot’ is not in list 2021-08-18 16:27:17 ERROR rasa.core.training.interactive - An exception occurred while recording messages.

Any idea why I get this error? Thanks for your help


Hello @Chrisprollsite

This might be a bug. What is the output of rasa --version for you?

Hi @j.mosig ! my rasa --version gives the following:

Any updates regarding this issue?

Sorry for my late reply. I just tried to reproduce it, but even with the exact same rasa version it works just fine for me. I’ve tried rasa interactive on moodbod (in the examples directory of the Rasa repo). Do you also find that it works on moodbot? In this case the problem has something to do with your particular bot and we can narrow it down further.

I’m also getting the same error

rasa --version
Rasa Version      :         2.8.6
Minimum Compatible Version: 2.8.0
Rasa SDK Version  :         2.8.2
Rasa X Version    :         None
Python Version    :         3.8.11
Operating System  :         Linux-5.11.0-7633-generic-x86_64-with-glibc2.17
Python Path       :         /home/jf/miniconda3/envs/try3/bin/python

I just did rasa init and then tried rasa interactive

Thanks. This is indeed a bug. We have an issue about this here: https://github.com/RasaHQ/rasa/issues/9517#issuecomment-931505788

1 Like

Same for me Rasa.server Error