Exception error from rasa interactive

Hi I am new to rasa. After creating an initial model with rasa, using “rasa init” I attempted to use rasa interactive to add new intents, stories. However I faced the below errors when I tried to save.

Hi @saltedEggChips,

This KeyError suggests to me that the intent was never set for the training example. Could you post the conversation that you had in interactive learning?

Hi @MetcalfeTom

The below is what I attempted:

Thanks @saltedEggChips,

Turns out you found a bug! For some reason this occurs when the entity type is the same string as the intent name.

I will post it on the Github board, for now you can avoid this by using a different term for the intent name or entity type (we usually use “cuisine” e.g. [pizza](cuisine))

Hi @MetcalfeTom

I have tried giving different names to the entity and intent, however the same errors are still being prompted.

Thanks again @saltedEggChips,

After some further digging I found where the error occurs and submitted a PR to remove it. Will be fixed in the next version - thanks for helping us improve! If you want to use interactive learning in the mean time, you can pull from the dumping-none-intents branch