Unable to use Rasa after OS update. Could not find a version that satisfies the requirement tensorflow<2.2,>=2.1 (from rasa)

Hello Rasa community!

I just updated my OS from Ubuntu 19.10 to 20.04 and I can’t run my project anymore. On my previous OS version I was using python 3.7 and now I’m using python 3.8, with pip version 20.0.2 . When I type rasa shell I get the following error message:

Traceback (most recent call last): File "/home/stavr/Desktop/venv/bin/rasa", line 6, in <module> from rasa.__main__ import main ModuleNotFoundError: No module named 'rasa'

I tried installing rasa again (pip install rasa) on a different virtual environment and I’m getting the following error:

ERROR: Could not find a version that satisfies the requirement tensorflow<2.2,>=2.1 (from rasa) (from versions: 2.2.0rc1, 2.2.0rc2, 2.2.0rc3, 2.2.0rc4, 2.2.0) ERROR: No matching distribution found for tensorflow<2.2,>=2.1 (from rasa)

I even tried solutions from different threads of this forum like pip install --upgrade tensorflow rasa which leads to error:

ERROR: rasa 1.10.1 has requirement tensorflow<2.2,>=2.1, but you'll have tensorflow 2.2.0 which is incompatible. ERROR: rasa 1.10.1 has requirement tensorflow-addons<0.8.0,>=0.7.1, but you'll have tensorflow-addons 0.10.0 which is incompatible. ERROR: rasa 1.10.1 has requirement tensorflow-estimator==2.1.0, but you'll have tensorflow-estimator 2.2.0 which is incompatible.

Using an older version of rasa won’t work since I already tried it. Can someone please help me with this?

Please try

    sudo apt-get install python3-pip python3-dev
    sudo pip3 install --upgrade https://storage.googleapis.com/tensorflow/linux/cpu/tensorflow-0.8.0-cp34-cp34m-linux_x86_64.whl 

Hey @godwin3737, when running the second command I’m getting this error:

ERROR: tensorflow-0.8.0-cp34-cp34m-linux_x86_64.whl is not a supported wheel on this platform.

What worked for me is this: Download anaconda, then create a new environment using python=3.6.0 Then try reinstalling, I should work after words.

What I did was to download and reinstall python 3.7 manually. Then I created a new venv and reinstalled rasa there. It finally worked, even though that’s exactly what I did with python 3.8 :thinking:

1 Like