Installing Rasa on Mac - ERROR

Dear all, I am new to Rasa community, and very excited to be here to make the first step of installing Rasa and then to create a quick bot for testing it. I would appreciate your help in the journey :slight_smile: I followed the instructions to install rasa on mac looking at this link : https://youtu.be/fqzsE70Rvr0

Please suggest how to install TensorFlow module. I am getting the following error:

python3.8 -m pip install rasa

Collecting rasa

Using cached rasa-1.10.2-py3-none-any.whl (510 kB)

Collecting kafka-python<2.0,>=1.4

Using cached kafka_python-1.4.7-py2.py3-none-any.whl (266 kB)

Requirement already satisfied: setuptools>=41.0.0 in ./venv/lib/python3.8/site-packages (from rasa) (49.6.0)

Collecting python-dateutil<2.9,>=2.8

Using cached python_dateutil-2.8.1-py2.py3-none-any.whl (227 kB)

Collecting pykwalify<1.8.0,>=1.7.0

Using cached pykwalify-1.7.0-py2.py3-none-any.whl (40 kB)

Collecting apscheduler<3.7,>=3.6

Using cached APScheduler-3.6.3-py2.py3-none-any.whl (58 kB)

Collecting colorhash<1.1.0,>=1.0.2

Using cached colorhash-1.0.2-py2.py3-none-any.whl (6.0 kB)

Collecting packaging<21.0,>=20.0

Downloading packaging-20.4-py2.py3-none-any.whl (37 kB)

ERROR: Could not find a version that satisfies the requirement tensorflow-addons<0.8.0,>=0.7.1 (from rasa) (from versions: 0.10.0, 0.11.0, 0.11.1, 0.11.2)

ERROR: No matching distribution found for tensorflow-addons<0.8.0,>=0.7.1 (from rasa)

Hello Rasa Community, So I tried all the ideas that I saw posted here by other members regarding a similar error, I have used various Python version from 3.6.0 to 3.8.0 with combination of pip versions but I have still no luck. Screen Shot 2020-09-09 at 10.19.24 PM

I really want to move to the next step of building a simple bot, I hope Rasa community can help me with suggestions on how to fix this “simple install” problem with Rasa!!! It shouldn’t be this difficult, or is it???

Appreciate the help in advance.