Tensorflow-addons

ERROR: Could not find a version that satisfies the requirement tensorflow-addons<0.9,>=0.8 (from rasa) (from versions: 0.5.0, 0.5.1, 0.5.2, 0.6.0, 0.7.0, 0.7.1) ERROR: No matching distribution found for tensorflow-addons<0.9,>=0.8 (from rasa)

When I try to install rasa through pip install rasa, the above error is what I’m getting. I’m working on MacOS in a virtual env that I created using python3 -m venv --system-site-packages ./venv, and my python version is 3.7.3. I’m not sure what the problem might me - it could be the version of python I’m using, in which case, what version is the best to work with rasa? I tried downgrading with brew but I haven’t been able to, so some help with that will also be appreciated!

6 Likes

Having the same issue with Python 3.7.6.

Hi, I am having the same issue. This started happening recently. Any ideas?

I am facing the same issue.

pip install rasa

Could not find a version that satisfies the requirement tensorflow-addons<0.9,>=0.8.

Do we need to downgrade to a specific version of rasa to be compatible with the available versions of the required tensorflow-addons library? These versions are: 0.5.0, 0.5.1, 0.5.2, 0.6.0, 0.7.0, 0.7.1

note that rasa 1.8 just came out that seems to use a newer version of TF, so rather than solving the problem you have now, you can try 1.8 (and probably have a new problem :sob:)

pip install rasa ==1.8

related solution to your problem with 1.7 and TF on this forum post:

After some digging around I was able to successfully install a previous version of 1.7.

pip install rasa==1.7.0

Need to install some libraries separately like tensorflow-cpu==1.15.0 as I am testing rasa on a mac-os.

1 Like

Hey @nikitajain18, try installing it using the below command which worked for me on Mac:

pip3 install --upgrade tensorflow-addons rasa

We are currently looking into this. Seems to be an issue with older OSX versions (10.13 and 10.14). tensorflow-addons had some issues and they didn’t release packages for these OS versions…

In any case, we are in contact with them, should be resolved shortly.

1 Like

I had the issue above on 10.15.2

every time mac os updates it breaks xcode and node-gyp…

Any updates on how to resolve this issue? I am having the same problem. I have tried all solutions posted in this thread so far.

OSX==10.13.6 rasa==1.8 python==3.7

I reverted to rasa 1.7 and retrained the model, now I’m running into this error: rasa_nlu.model.UnsupportedModelError: The model version is to old to be loaded by this Rasa NLU instance. Either retrain the model, or run withan older version. Model version: 0.0.0 Instance version: 0.15.1

Any insight would be greatly appreciated!

I am having the same issue :frowning:

Same issue here. If anybody happen to have a wheel for the TensorFlow version required by Rasa (==1.15), I guess it would be the easiest solution. Or maybe adjust the requirement in the Rasa itself?

@nlp can you update your OSX? I’m on 10.15.3 and managed to get around this issue.

btw Rasa folks you might want to create a little script like rasa env that would print out the os env, rasa version etc for bug reports. I was working on another project that did this and it was super easy for ppl to use and helpful. node based but …

Same issue on ubuntu 18, so not just mac related

Hello guys,

I just update pip to latest version and it worked (no more Tensorflow version related problems):

pip install --upgrade pip

Hope it will help

3 Likes

I am also facing this issue when trying to install rasa. OS - Windows 10 enterprise. Python - 3.8.2 pip - Upgraded to latest which is: 20.0.2

Command I used is what is given in the Installation page - pip3 install rasa

Error that I got -

ERROR: Could not find a version that satisfies the requirement tensorflow-addons<0.9,>=0.8 (from rasa) (from versions: none) ERROR: No matching distribution found for tensorflow-addons<0.9,>=0.8 (from rasa)

Didn’t help mate. Still got the same error.

Downgrading python to 3.7.7 worked. Tensorflow add-on problem went away.

I am facing the same problem, and my python version is 3.7.7 already, not sure what to do? anyone can help please? i tried rasa version 1.7 and 1.8 as well with no luck

ERROR: Could not find a version that satisfies the requirement tensorflow-addons<0.9,>=0.8 (from rasa) (from versions: none) ERROR: No matching distribution found for tensorflow-addons<0.9,>=0.8 (from rasa)