Unable to continue the conversation after the fallback action triggered by RASA Core

For an unknown message, RASA core is triggering the fallback action. But after the fallback action is triggered even if i type the known message, RASA core keeps giving the fallback action.

Basically, i’m trying to achieve a scenario where the user types an unknown message anywhere in the middle of the conversation and later enters a known message

Have you tried clearing all your existing stories and using interactive learning to generate stories for this? I often found myself having either made an error in the stories or having changed something that led to inconsistent behavior. I’d try training a completely empty model interactively and see if it works then. If yes, review all your stories and remove the ones that might be conflicting. Add these again through interactive training.

That shouldn’t happen. Are you using


Hi Srikar, I was not aware of this action. Is that an inbuilt action?

Can you say which version of RASA are you using? Also, can you show you actions and domain file where you’ve defined this?

Yes, that is an inbuilt function.

Sorry to deviate the topic but now i’m not able to avoid these annoying messages.

Seems like it’s not able to fetch that file. Did you modify anything in the core file?

command to train rasa-core python3 -m rasa_core.train -d domain.yml -s data/stories.md -o models/current/dialogue -c policies.yml --augmentation 0

command to run rasa-core python3 -m rasa_core.run -d models/current/dialogue -u models/current/nlu --endpoints endpoints.yml

i have the same domain.yml, stories.md and policies.yml files. Didn’t change anything

Hi Ghouse check out this document. This has the source code for default fallback action. I think this can solve your problem. https://rasa.com/docs/core/_modules/rasa_core/actions/action/#ActionDefaultFallback so you can change your fallback action in this if you want. and run it as a custom action. UserUtterenceReverted() is returned which I think sets the conversation back 1 step. so the bot will display a default action but internally it will go back a step in conversation.

Thanks Akshit. I will give it a try. Meanwhile any idea how to get the below issue resolved.

I’m not sure at which place it it trying to find the file “visualization.dot”

What was the command that you ran in cmd?

python3 -m rasa_core.run -d models/current/dialogue -u models/current/nlu --endpoints endpoints.yml

the visualization.dot issue is resolved but the original fallback with custom action is still there




Errors during converstaion

Can anyone let me know if i’m missing any configuration?

Tried adding the following lines to actions.py but still the same issue

from rasa_core_sdk.events import UserUtteranceReverted

Issue is resolved after using ActionReverted() instead of UserUtteranceReverted()

Sorry, I didn’t get a notification about your later posts. I guess in version 0.12, UserUtteranceReverted() has been replaced with ActionReverted().

Hello @Ghouse ,

Could you tell me the root cause and how to fix below issue?

Did you add UserUtteranceReverted() in your default fallback action?