My action_default_fallback is being triggered repeatedly breaking the conversation flow


I am facing an issue when testing my bot. For every valid input (even the first one - greet), the system recognises action_default_fallback(0.20) repeatedly:

version: “2.0” stories:

  • story: Story from Conversation ID steps:
    • intent: affirm
    • action: action_default_fallback
    • action: action_default_fallback
    • action: action_default_fallback

My config.yml includes the following:

> policies:
>   - name: MemoizationPolicy
>     max_history: 7 
>   - name: TEDPolicy
>     max_history: 7 
>     epochs: 1
>   - name: RulePolicy
>     core_fallback_threshold: 0.2
>     core_fallback_action_name: "action_default_fallback" 

Also, my FallbackClassifier uses the following:

>   - name: FallbackClassifier
>     threshold: 0.6 
>     ambiguity_threshold: 0.05

Can you please advise me on how to solve this? Thanks!

@ml2021 Hey, If your code is right and you seeing the fallback, can I ask you to delete all the previous trained model and re-train and try.

@nik202 It did not work. No matter what I type, action_default_fallback is triggered. Any suggestion?

@ml2021 are you following any specific configuration or just normal, can you share your story? and why are you using this any specific reason?

- name: FallbackClassifier
      threshold: 0.6 
      ambiguity_threshold: 0.05

@nik202 Configuration is normal. Stories follow my previous paths in conversation, nothing strange. I tried to remove parameters of FallbackClassifier so it uses default ones, and now I type “hello” and get the following message:

WARNING rasa.core.processor - Circuit breaker tripped. Stopped predicting more actions for sender …

After this the system does no retrieve more responses, no matter what I type. What should I do?


Try this:

# Configuration for Rasa NLU.
language: en
  - name: WhitespaceTokenizer
  - name: RegexFeaturizer
  - name: LexicalSyntacticFeaturizer
  - name: CountVectorsFeaturizer
  - name: CountVectorsFeaturizer
    analyzer: "char_wb"
    min_ngram: 1
    max_ngram: 4
  - name: DIETClassifier
    epochs: 100
    ranking_length: 5
    constrain_similarities: true
    model_confidence: linear_norm
  - name: EntitySynonymMapper
  - name: ResponseSelector
    epochs: 100
    constrain_similarities: true
    model_confidence: linear_norm

  # - name: DucklingHTTPExtractor
  #   url: http://localhost:9000
  #   dimensions:
  #   - question
  #   - answer
  #   timezone: UK/London
  #   timeout: 3

# Configuration for Rasa Core.
  - name: MemoizationPolicy
  - name: TEDPolicy
    max_history: 5
    epochs: 100
  - name: RulePolicy
    nlu_threshold: 0.4
    core_threshold: 0.4
    fallback_action_name: "action_default_fallback"

@ml2021 can you please share your story and rule file, you need to sort your story I guess. @ml2021 please run the rasa in debug mode rasa shell --debug and share the error screenshot and even action server logs.

1 Like

@ml2021 Hi, I hope you solved this issue or still having some errors, feel free to share and discuss.

@nik202 Sorry that did not solve the issue, I will have a closer look to my stories, check logs and update here if successful.

Have you solved that problem? I am facing same