[Solved] Chatbot not responding. Only ... visible

For my fellow students running into the issue that the chatbot does not output any text. You only see (…)

I saw similar topics on the forum but in my case the error was not enough disk space on the server.

I created a virtual machine using google cloud. Just like the rasa master video. Unfortunately, I made the mistake of not configuring the disk space from the default 10 gb to 50 gb. This results in the chatbot not responding.

I know it sounds unbelievable, but only after increasing the disk space the issue was resolved. So try it out - you might save yourself some hours :wink: . The minimal requirement is 50 gb.

2 Likes

I’m trying this, as I had a disk with 10 gb assigned to Rasa in google cloud, but a second one with 100 gb, anyway, I assigned 50 gb to the disk with rasa, will report back in 30 mins! as I have seen many people dealing with this problem and because of the lack of logs its hard to pinpoint what is causing that.

How did you find the problem? Thanks for reporting your solution :slight_smile:

Luckily you can just increase the disk size in google cloud easily!

I tried a lot of stuff. First I deployed using the quick-install method. Then I thought that maybe using the docker approach would fix it.

This did not fix it.

But when you use the docker approach you can run it like this: sudo docker-compose up

You will get a lot of debug information and I just let it run on the side. Out of frustration I just rebooted the virtual machine, did the command again and noticed in super tiny glimpse that rasa-x was complaining about disk space.

So i guess it was just dump luck in my case. Some useful feedback in the front-end would be a better approach :wink:

1 Like

It worked!! Thanks for sharing again.

Increasing the disk space also worked for me. My setup was:
OS: Ubuntu 18
Rasa X: 0.34.0
Install method: Docker-Compose Manual Install

I noticed that the partition where the docker images are stored only has 16 GB.
I asked our Infra Engineer for more space, and he gave me a new partition of 100 GB.
I ran “docker-compose down” then “docker-compose up -d” but still no luck, the bot still did not reply. Little did I know that the docker data folder should be in the bigger partition (50 GB or more) So i did the following to move the docker data folder:

  1. create file daemon.json in /etc/docker/ and add the following:
    {
    “data-root”: “<path/to/new/docker-data/folder>”
    }

  2. restart docker service:
    systemctl stop docker
    systemctl start docker

After that I did the “docker-compose up -d” thing again, and the bot is now replying in the interactive learning mode.
Thanks for telling us about the disk space requirement, I was going nuts over this issue.

1 Like