Simple Question

I’m trying to run the standard install with the standard starter package on anaconda running locally on a Mac.

I am able to successfully install everything and can run the - make train-nlu - command but can not run the - make run-nlu - command

I receive the following error

make: *** No rule to make target `run-nlu’. Stop.

It must be simple to fix but I am new to Rasa

Where did you see run-nlu? I use starter-pack-rasa-stack, there you should do: make train-nlu make train-core make action-server make cmdline

Its in the simple get started video -

That is maybe outdated, I was reading the doc from the GitHub readme (GitHub - RasaHQ/starter-pack-rasa-stack). Also I forgot to mention above, but train-core failed for me, I had to edit the Makefile and remove the --epochs 200 parameter for it to run.

Thx @jwickers - that worked - I also edited the Makefile and removed the --epochs 200 .

Now when I run the - make cmdline -

I get this:

Gis-MacBook-Pro:starter-pack-rasa-stack gili$ make action-server python -m rasa_core_sdk.endpoint --actions actions INFO:main:Starting action endpoint server… INFO:rasa_core_sdk.executor:Registered function for ‘action_joke’. INFO:main:Action endpoint is up and running. on (‘’, 5055) make cmdline

And its just stuck

any idea whats happening?

@MHWithnail the starterpack you were looking into was only for nlu, that’s why it has run-nlu function :slight_smile:

Speaking of the second issue, it’s because there were some changes in the codebase with the new Rasa Core release. I will update the repo in a few minutes.

Ha, it’s not stuck, make action-server starts a server (that you stop later with CTRL-C), you need to go another terminal to run make cmdline

I have just updated the repo. Also made it more clear in readme, that you have to start the action server on separater terminal, just like @jwickers suggested you already :slight_smile:

thanks @jwickers and @Juste