Should all models in model directory show up in rasa X

When I use Rasa X to train a model, it displays in the UI.

But before training models using Rasa X, if I use rasa train, I have models in my /model directory, but those aren’t displayed.

Is this expected behavior? When I try to update using the upload feature, I get the error, model already exists. Is there a config file for Rasa X I need to modify to display and use these models or are they incompatible?

I’m not sure that Rasa X “polls” that directory for changes regularly. Have you tried restarting the Rasa X service? It may grab the contents of that directory only at start-up.

I have tried restarting rasa X, no change in UI display. I’ve also tried the import functionality, via both UI and cmd line but it says the file with the same name already exists.

My best answer at this moment under this versions is that models trained in the cmd line via rasa train, don’t display in Rasa X

Rasa Version     : 2.0.2
Rasa SDK Version : 2.0.0
Rasa X Version   : 0.33.2
Python Version   : 3.8.5
Operating System : Linux-4.19.128-microsoft-standard-x86_64-with-glibc2.29

@tyd Tyler, since I saw you comment on my other thread re: a bug, can you take a look at this and confirm my solution is correct?

@sparklie3 Are you using Rasa X locally by running the rasa x command or have you deployed it on a server?


@sparklie3 This sounds like a bug. I have not had a chance to verify it yet though. Can you please create a bug report for it?

Okay. Here’s the ticket models created by rasa train in cmdline doesn't show up in Rasa X local machine · Issue #7319 · RasaHQ/rasa · GitHub