Share your bot - Local Mode with ngrok -- Generate Link does not work

I am using Rasa 2.0.2 and Rasa X 0.33.0. I want to share my bot with testers using the Local Mode and ngrok. I have started ngrok tunnel and it works fine. But when I try share it with Share Your Bot under the Conversations tab in Rasa X UI, and click on “Generate Link” it does not generate the link. Nothing happens. Has anyone run into this issue?

Hey @ftarlaci!

I’ve just tried to reproduce it with Rasa X 0.33.0, and it generated the link without any issues.

Could you please provide us with more details about your environment? How did you install Rasa X? What browser do you use? It’d also be helpful to take a look at the developer console of your browser to see if there are any errors there.

Thank you for the timely response. I installed Rasa Open Source in a conda environment with the command pip3 install rasa. And Rasa X with the Local Mode installation command:

pip3 install rasa-x --extra-index-url

I followed the instructions for ngrok from the docs, I added my ngrok authtoken in the config file as described on the ngrok docs. The link generation worked once without a problem, and I was able to generate a link but after I made changes to the bot, I wanted to share it again. This time it didn’t work. When I inspect the dev tools console, I see that there is an unauthorized error regarding chat/chatToken . I checked my ngrok tunnel and it seems to be working fine as well. I killed and restarted ngrok tunnel to see if it would make a difference. However, I am still having the same issue with not being able to generate the link to share.

I am on Mac & Chrome

I looked a little closer in the dev tools and the error seems to be logged as below:

"version":"0.33.1","status":"failure","message":"The payload schema is invalid.
Please check the API specification at https:\/\/\/docs\/rasa-x\/api\/rasa-x-http-api\/ 
for the correct schema.","reason":"WrongSchema","details":...