Sanic and sanic-plugins-framework version incompatibility error while installing Rasa

ERROR: sanic-plugins-framework 0.8.2.post1 has requirement sanic<=19.6.3,>=0.8.3, but you’ll have sanic 19.9.0 which is incompatible.

Showing this error every time I’m trying to install rasa. Don’t know how to solve this. Anyone here who faced this problem and solved or can help me to get rid of this error?

Stored in directory: /home/designer2_cwork/.cache/pip/wheels/ba/66/5d/9e469ea8f64bb7c95aaa6c467c560741a11366e5769abf7fec Building wheel for terminaltables (setup.py) … done Created wheel for terminaltables: filename=terminaltables-3.1.0-cp36-none-any.whl size=17910 sha256=88ecbc76dcb661258482449b76dae162293be9eff1694ad03424cf056e6049a9 Stored in directory: /home/designer2_cwork/.cache/pip/wheels/30/6b/50/6c75775b681fb36cdfac7f19799888ef9d8813aff9e379663e Building wheel for webexteamssdk (setup.py) … done Created wheel for webexteamssdk: filename=webexteamssdk-1.2-cp36-none-any.whl size=85806 sha256=5982deaf9e2a76206c2084d6ea97484434feff9f45bf4b1ac08163ae9e145c85 Stored in directory: /home/designer2_cwork/.cache/pip/wheels/ae/5f/fb/705cb87c56fb25aed2fa6795a1c751ca83b79fc76f69e37d0c Successfully built slackclient sanic-jwt twilio terminaltables webexteamssdk

ERROR: sanic-plugins-framework 0.8.2.post1 has requirement sanic<=19.6.3,>=0.8.3, but you’ll have sanic 19.9.0 which is incompatible.

Installing collected packages: multidict, python-engineio, idna-ssl, yarl, async-timeout, attrs, typing-extensions, aiohttp, ruamel.yaml, gast, python-dateutil, docutils, jmespath, botocore, s3transfer, boto3, absl-py, gin-config, future, mesh-tensorflow, Pillow, tqdm, numpy, scipy, cloudpickle, pyglet, opencv-python, gym, dopamine-rl, decorator, tensorflow-probability, kfac, h5py, requests, setuptools, protobuf, tensorflow-hub, tensorflow-gan, gunicorn, pypng, rsa, cachetools, google-auth, google-auth-httplib2, uritemplate, google-api-python-client, Werkzeug, Jinja2, itsdangerous, flask, bz2file, mpmath, sympy, oauth2client, termcolor, wrapt, dill, promise, googleapis-common-protos, tensorflow-metadata, tensorflow-datasets, greenlet, gevent, tensor2tensor, python-telegram-bot, pika, wcwidth, prompt-toolkit, questionary, fbmessenger, jsonpickle, mattermostwrapper, websocket-client, slackclient, PyJWT, sanic-jwt, pytz, twilio, SQLAlchemy, terminaltables, requests-toolbelt, webexteamssdk, colorclass, redis, scikit-learn, kiwisolver, pyparsing, cycler, matplotlib, dnspython, pymongo, docopt, pykwalify, colorhash, pyrsistent, more-itertools, zipp, importlib-metadata, jsonschema, rocketchat-API, async-generator, h11, rfc3986, hyperframe, hpack, h2, httpcore, requests-async, uvloop, httptools, ujson, aiofiles, websockets, sanic, networkx, tabulate, python-crfsuite, sklearn-crfsuite, sanic-plugins-framework, sanic-cors, packaging, pydot, tzlocal, apscheduler, tensorflow-estimator, keras-preprocessing, google-pasta, grpcio, keras-applications, markdown, tensorboard, opt-einsum, astor, tensorflow, python-socketio, ConfigArgParse, humanfriendly, coloredlogs, rasa-sdk, rasa Found existing installation: attrs 17.4.0 Not uninstalling attrs at /usr/lib/python3/dist-packages, outside environment /home/designer2_cwork/venv Can’t uninstall ‘attrs’. No files were found to uninstall. Found existing installation: requests 2.18.4 Not uninstalling requests at /usr/lib/python3/dist-packages, outside environment /home/designer2_cwork/venv Can’t uninstall ‘requests’. No files were found to uninstall. Found existing installation: setuptools 39.0.1 Uninstalling setuptools-39.0.1: Successfully uninstalled setuptools-39.0.1 Found existing installation: Jinja2 2.10 Not uninstalling jinja2 at /usr/lib/python3/dist-packages, outside environment /home/designer2_cwork/venv Can’t uninstall ‘Jinja2’. No files were found to uninstall. Found existing installation: PyJWT 1.5.3 Not uninstalling pyjwt at /usr/lib/python3/dist-packages, outside environment /home/designer2_cwork/venv Can’t uninstall ‘PyJWT’. No files were found to uninstall. Found existing installation: jsonschema 2.6.0 Not uninstalling jsonschema at /usr/lib/python3/dist-packages, outside environment /home/designer2_cwork/venv Can’t uninstall ‘jsonschema’. No files were found to uninstall. Successfully installed ConfigArgParse-1.0 Jinja2-2.10.3 Pillow-7.0.0 PyJWT-1.7.1 SQLAlchemy-1.3.12 Werkzeug-0.16.0 absl-py-0.9.0 aiofiles-0.4.0 aiohttp-3.6.2 apscheduler-3.6.3 astor-0.8.1 async-generator-1.10 async-timeout-3.0.1 attrs-19.3.0 boto3-1.11.0 botocore-1.14.0 bz2file-0.98 cachetools-4.0.0 cloudpickle-1.2.2 colorclass-2.2.0 coloredlogs-10.0 colorhash-1.0.2 cycler-0.10.0 decorator-4.4.1 dill-0.3.1.1 dnspython-1.16.0 docopt-0.6.2 docutils-0.15.2 dopamine-rl-3.0.1 fbmessenger-6.0.0 flask-1.1.1 future-0.18.2 gast-0.2.2 gevent-1.4.0 gin-config-0.3.0 google-api-python-client-1.7.11 google-auth-1.10.0 google-auth-httplib2-0.0.3 google-pasta-0.1.8 googleapis-common-protos-1.6.0 greenlet-0.4.15 grpcio-1.26.0 gunicorn-20.0.4 gym-0.15.4 h11-0.8.1 h2-3.1.1 h5py-2.10.0 hpack-3.0.0 httpcore-0.3.0 httptools-0.0.13 humanfriendly-4.18 hyperframe-5.2.0 idna-ssl-1.1.0 importlib-metadata-1.4.0 itsdangerous-1.1.0 jmespath-0.9.4 jsonpickle-1.2 jsonschema-3.2.0 keras-applications-1.0.8 keras-preprocessing-1.1.0 kfac-0.2.0 kiwisolver-1.1.0 markdown-3.1.1 matplotlib-3.1.2 mattermostwrapper-2.1 mesh-tensorflow-0.1.9 more-itertools-8.1.0 mpmath-1.1.0 multidict-4.6.1 networkx-2.3 numpy-1.18.1 oauth2client-4.1.3 opencv-python-4.1.2.30 opt-einsum-3.1.0 packaging-19.2 pika-1.0.1 promise-2.3 prompt-toolkit-2.0.10 protobuf-3.11.2 pydot-1.4.1 pyglet-1.3.2 pykwalify-1.7.0 pymongo-3.10.1 pyparsing-2.4.6 pypng-0.0.20 pyrsistent-0.15.7 python-crfsuite-0.9.6 python-dateutil-2.8.1 python-engineio-3.11.2 python-socketio-4.4.0 python-telegram-bot-11.1.0 pytz-2019.3 questionary-1.4.0 rasa-1.6.1 rasa-sdk-1.6.1 redis-3.3.11 requests-2.22.0 requests-async-0.5.0 requests-toolbelt-0.9.1 rfc3986-1.3.2 rocketchat-API-0.6.36 rsa-4.0 ruamel.yaml-0.15.100 s3transfer-0.3.0 sanic-19.9.0 sanic-cors-0.9.9.post1 sanic-jwt-1.4.0 sanic-plugins-framework-0.8.2.post1 scikit-learn-0.20.4 scipy-1.4.1 setuptools-45.0.0 sklearn-crfsuite-0.3.6 slackclient-1.3.2 sympy-1.5.1 tabulate-0.8.6 tensor2tensor-1.14.1 tensorboard-1.15.0 tensorflow-1.15.0 tensorflow-datasets-1.3.2 tensorflow-estimator-1.15.1 tensorflow-gan-2.0.0 tensorflow-hub-0.7.0 tensorflow-metadata-0.21.0 tensorflow-probability-0.7.0 termcolor-1.1.0 terminaltables-3.1.0 tqdm-4.41.1 twilio-6.35.2 typing-extensions-3.7.4.1 tzlocal-2.0.0 ujson-1.35 uritemplate-3.0.1 uvloop-0.14.0 wcwidth-0.1.8 webexteamssdk-1.2 websocket-client-0.54.0 websockets-8.1 wrapt-1.11.2 yarl-1.4.2 zipp-0.6.0

Hi @raselparvez

Thank you for bringing this up! It happens since sanic has released a new module and pip can’t handle this. We’re working on a proper solution. In the meantime, if you install from source, add sanic-plugins-framework==0.8.2 to requirements.txt and it should work.

Thanks! It worked :slightly_smiling_face:

How to install from source…?

I am getting this Error while running this commandpip install rasa-x --extra-index-url https://pypi.rasa.com/simple

Error- sanic-plugins-framework 0.8.2.post1 has requirement sanic<=19.6.3,>=0.8.3, but you’ll have sanic 19.9.0 which is incompatible.

Hi, here a link to build from source

Just add sanic-plugins-framework==0.8.2 to requirements.txt before to $ pip install -r requirements.txt

But what if you don’t install it from source? Will RASA work properly until there’s a proper solution?

1 Like

I’m sorry but installing from source is not an option to me. I’ve checked installation in a different enviroment a couple of months ago and this didn’t happen!

I need to do things in the same exact way because we have documented installation process. And sadly I cannot ensure that all the enviroments on where I have to install RASA are exactly identical…

1 Like

It was already in the requirements.txt file I could see

Hi Tiziano,

Yes, this has already been added to requirements.txt

pip3 install rasa still generates error with sanic, so I continue installing from source

@MarceloVourakis

Thank you for your comment. It should work again now. Sorry for the inconvenience, but we cannot prevent Sanic from releasing breaking changes in a patch version. We are looking into better ways of handling dependencies.

Hi all, best solution which I have come across requires little effort and some time. I was facing the same problem and I tried several suggestions provided on various platforms. I suggest whatever package is causing issue you can remove it from your system and again try to install Rasa again. It will automatically install the compatible package. I tried this and in fact I found 15 packages which were causing issues even though they were already installed. This may lead to a series of un-installation processes but at the end this will work. You can try this in any OS (windows or linux) or platform like anaconda etc. Hope this will help the members of the community/forum.

Hi @juanmariareina, You can uninstall the problematic package and again install the Rasa. while installation, it will detect the missing package and automatically download the compatible package for you.

Hi, can you give me the version of rasa and sanic-plugin-framework that work for you now? I am getting sanic exception in 5055 action server port when I start the action server. Though 5005 is working fine without any issue.