I am trying to install Rasa framework 1.6.1 on macOS but
sanic package is having some sort of circular dependency with other packages. I am getting following error while doing
pip3 install rasa
ERROR: sanic-plugins-framework 0.8.2.post1 has requirement sanic<=19.6.3,>=0.8.3, but you'll have sanic 19.12.2 which is incompatible.
If I manually install
sanic 19.6.3 then it complains that it needs
sanic lower than 19.6.3. I tried building form source but same problem comes up.
How do I sort out this dependency problem? Thanks in advance.