Sanic error while installing rasa 1.7.0

Getting following error while installing rasa 1.7.0

rasa-sdk 1.7.0 requires sanic<20.0.0,>=19.12.2, but you’ll have sanic 19.9.0 which is incompatible. rasa-sdk 1.7.0 requires sanic-cors<0.11.0,>=0.10.0b1, but you’ll have sanic-cors 0.9.9.post1 which is incompatible.

Hi @Dhiraj_Gite, your environment already contains versions of sanic that won’t work with rasa. We recommend creating a new virtual environment to install rasa to avoid errors like this.