Running rasa on 0.0.0.0 instead of localhost in container

I’m running 2.8.1 container

it binds on localhost:5005 again I need to use Nginx reverse proxy and all to properly map ports

Is there any way to run rasa on 0.0.0.0:5005 instead of localhost:5005 inside the container?

Hi @nik202

I’m aware of using nginx

I’m looking for a way to run rasa on 0.0.0.0:5005 instead of localhost:5005 inside the docker container so that for development sake I can directly do port mappings without all the nginx configuration

No need to do that.

Action server by default runs on 0.0.0.0:5055

I’m looking for solution who tried running the same for rasa container as well…

Docker inspection has got nothing to address binding as far as I know

I think you didn’t get my question it’s independent of which one I want to run… according to heading it’s more of what and how I want to run :slight_smile:

And also it has nothing to do with docker networking it’s more of rasa thing than a docker network thing :slight_smile:

And I have gone through all these the threads on the forum there’s no clear proper solution. So I opened one.

What happens if you use -p option to map host’s 5005 port with the docker container 5005 port while starting it ?

By Default, Rasa runs on host=0.0.0.0, so no need to specify it

So if in your case, 0.0.0.0 is not pointing to localhost or you are not able to connect , it is likely that your /etc/hosts is not configured with the map of 0.0.0.0 to localhost or 127.0.0.1

while i understand this might be what you need, i would highly recommend against doing so because it essentially opens your server to potential attacks. instead use a proxy to protect direct exposure on the internet.

1 Like

Yes,

I found that later. This is the correct answer.

I got a little bit confused as in the logs in was showing localhost:5005 instead of 0.0.0.0:5005

Later on, I found out it was the issue with kubs provider where by default they were not exposing the 5005 port as it was reserved for java development. etc hosts file were all good.

Anyways, rasa by default runs on 0.0.0.0 just in the logs it’s showing as locahost.