Change localhost to Domain Name Docker

When i run rasa on docker, it will only start on localhost:5005, i want to change it to 34.343.234:5005

@henseljahja its a live IP? What is this 34.343.234?

no its is not, i just want to specify to run into domain 34.343.234 instead of localhost

@henseljahja are you sure it is domain IP? Which class its belong? can you able to ping from cmd?

does you know to change the bind address? instead of localhost

@henseljahja Where you deploying your chatbot? or just running on localhost using shell command ?

im trying to deploy my chatbot, using docker container

@henseljahja but dear, where what is your front end? or you just running on docker container? can you share your docker file please.

Im using botfront, and right now my container already in deployment, but i just really need to change the back endpoint from localhost to custom domain name Heres my docker file

FROM rasa/rasa:2.1.3

# ARG STAGE

ADD poetry.lock pyproject.toml ./
ENV POSTGRESQL_SCHEMA='chatbot'
ENV DEFAULT_NLU_FALLBACK_THRESHOLD = 0.3
ENV DEFAULT_NLU_FALLBACK_AMBIGUITY_THRESHOLD = 0.1
ENV DEFAULT_CORE_FALLBACK_THRESHOLD = 0.3
ENV DEFAULT_REQUEST_TIMEOUT = 60 * 5  # 5 minutes
ENV DEFAULT_RESPONSE_TIMEOUT = 60 * 60  # 1 hour
ENV DEFAULT_LOCK_LIFETIME = 60  # in seconds
# ENV 
COPY . .
EXPOSE 5005 5432 6005
RUN python app.py

CMD ["run", "-m", "models", "--enable-api", "--cors",  "'*'", "--debug"]

but when i run it, it only run on the local host of the cloud, not on the specific port of the cloud

@henseljahja I am sorry for late reply, as you not mentioned @ so I not get the notification try add @ while mention the person id. Is this problem still persist?