Run rasa on the server (IP_address:5005) instead of localhost:5005

I deployed rasa on our server and ran it jusing 'rasa run --cors “*” `. and in terminal it showing ‘Starting Rasa server on http://localhost:5005’. I need to run it as Starting Rasa server on http://ipaddress:5005

Where should i change the interface ip address.

Hi @kabeer if it’s starting on your server like that, it means it’ll be accessible through that IP address. But you need to make sure the port 5005 is exposed if you want to use it outside the server. It’s just launching on the localhost of that server.

Thanks, @akelad. It working.

Hi @kabeer & @akelad ,

I tried changing the localhost to ip but still its displaying as local host when I run " rasa run -m models --enable-api --cors “*” --debug "

I changed localhost to ip a address in --credentials-credentials.yml

Thank you

1 Like

@Aashay1, You don’t have to change anything to run rasa on the server. Just deploy it on the server and run. Then you can access it via the valid IP address. Note: If you want to use custom actions, maybe you want to change the localhost to IP address in endpoints.yml file.

1 Like

I think @Aashay1 was referring to the fact that it should not report that it is running on “localhost” - the correct message would be:

server is up and running on http://0.0.0.0:5005

localhost is a different (loopback) address, 127.0.0.1, and is not externally reachable.

Hello @Aashay1 Please can you show me your credentials.yml file please i wanna change the localhost too Thank you And please i should run it with the same commande you mentioned right

i lunched it on the localhost on my server but still not answering

Please can you help @akelad

@kabeer Please show me your endpoint.yml file