Regarding improper response from chatbot

Hello guys , I am very much new to rasa and i got started with ipl bot blog(Learn how to Build a Chatbot in Minutes using Rasa) i train the nlu and core part like it’s mention in blog and pass api key but its not working chatbot unable to handle the simple queries ,I am attaching screenshot for your reference According to me there is some issue in my actions.py file not sure .

and there is no issue with api key i have checked its giving proper response and i have one more doubt like why actions.py file is not returning anything . and Do i need to modify actions.py and if i need to modify then how will modify …

Hello @Beherasaptami,

Welcome to the community!!!

I’m not so sure your actions in the issue here, it looks like the training isn’t right, do you have examples showing how your stories are setup currently?

The fact it just responds bye tells me most likely the training setup isn’t right.

Hey i am new to rasa so i just follow this blog (Learn how to Build a Chatbot in Minutes using Rasa) nd trainning go well like i didn’t get any error can you please check this blog once .

Well something isn’t working right if you followed that blog and it doesn’t work.

I would really need to see your stories.md file and nlu.md file to understand what training issue you are having here, as I previously stated this doesn’t look like it is even hitting your action server yet, its just classifying your intent incorrectly it appears or doesn’t have enough training data.

If you are also looking for an official tutorial from Rasa I would also recommend Building contextual assistants with Rasa Forms which goes over forms, slots and the overall basics of Rasa.

nlu_data.md (1.4 KB) stories.md (662 Bytes) I am attaching stories.md and nlu.md files for your reference .

Ok give me a few I’ll test this out on a bot and see what is up.

Thanks

It works ok for me, also that API appears to be deprecated now so can’t really test that but the flow works fine for me with a basic rasa bot created with rasa init then I put your nlu and story data in.

I also made sure the action server was running so this would respond correctly via rasa run actions --actions actions - Make sure you did this if not it could be the issue but seems to work for me even without the server running just gives an error.

Ignore the action error it is because I didn’t setup that API stuff but you can see the proper response back

The source code for this blog is a little out of date, I’d recommend creating a new bot like I did and move the training data into it and your action.py file and see what you get.

I was using Rasa version 1.3.9 for this test which is the latest code.

okay will try and let you know …thankyou

I got a similar issue once. Before RASA 1.x, I train NLU and Core with 2 different make commands (make train-nlu end make train-core like in the tutorial).

But RASA 1.0 introduce fingerprint and date in model training. So when I train like before, RASA run only load the last trained model (Core or NLU but not both). So when I was running RASA, the bot didn’t work correctly because one part was missing. Maybe it’s the same here.

Did you train your Core and NLU model separately ? Or are you using the rasa train command ?

Yea this sounds more like what might be occurring

Hey i tried using rasa init and trained using rasa train but no luck m getting same issue and the api key is (2olY2OGxATW2hYav9aJi10DzZQG2) can you check once whether its working for you .

This could be the issue can you try with the rasa train command and see the results?

Thanks

Hey i tried all the alternatives but no luck …i guess there is some issue with action.py and domain.yml file , maybe m missing something like i am returning “action_match_news” but its not declared in domain.yml , i am sending you whole folder structure for ur reference canyou please check once like where i am wrong . rasa02.zip (2.1 MB) and it throwing following error

You just need to uncomment this section in your endpoints.yml file, this is required for the action server to work. Also ensure you start the action server before the bot using rasa run actions --actions actions

Section to uncomment:

action_endpoint:
 url: "http://localhost:5055/webhook"

Works fine for me after doing that:

hey i tried now but i am getting this

i think m doing something wrong in actions.py file

I honestly am not sure what you are doing wrong, I literally took your code uncommented the line I told you to fix and ran the action server then the bot

Double check your endpoints.yml file and make sure it is correct

see the actions.py file its returning [ ] this i think it should return something and action_match_news is missing in domain.yml file . i think this might be the issue

well like I mentioned I didn’t change anything in your zip file but the endpoints.yml and it worked perfectly fine for me.

yes i also did the same but are you getting answer from ipl bot like are you getting response as actions properly

Yes I am look at the screenshot I sent it all works perfectly fine. Are you running this all locally? The reason you aren’t getting a response is some issue related to your actions server. Ensure the action server is running, then in another window you would run the bot and it all should work.

I mean I can zip up your code and send it back but all I changed was the one section I already mentioned.