Rasa X: the bot is hanging, 'listening', instead of answering


I have a problem when trying to converse with the bot using Rasa X: the bot is not responding, it is hanging, ‘listening’, no matter what question I am asking. The bot responds well when I am using the command prompt.

In my Anaconda prompt I get the following error:

WARNING:rasax.community.services.event_consumers.event_consumer:Saving event failed due to an 'IntegrityError'. This means that the event is already stored in the database. The event data was '{"sender_id": "6cf8714191eb42ed9d3f1d638b6749a4", "event": "action", "timestamp": 1590582983.2550197, "name": "action_listen", "policy": null, "confidence": null}'. (sqlite3.IntegrityError) UNIQUE constraint failed: conversation_event.conversation_id, conversation_event.timestamp, conversation_event.type_name
[SQL: INSERT INTO conversation_event (conversation_id, type_name, timestamp, intent_name, action_name, slot_name, slot_value, policy, is_flagged, data, evaluation, rasa_environment) VALUES (?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?)]
[parameters: ('6cf8714191eb42ed9d3f1d638b6749a4', 'action', 1590582983.2550197, None, 'action_listen', None, None, None, 0, '{"sender_id": "6cf8714191eb42ed9d3f1d638b6749a4", "event": "action", "timestamp": 1590582983.2550197, "name": "action_listen", "policy": null, "confidence": null}', None, 'production')]
(Background on this error at: http://sqlalche.me/e/gkpj)

Could you please tell me how to fix this problem?

Thank you, and have a great afternoon.

Hi @Titus! What Rasa X version are you currently using? Are you running it via docker-compose, Kubernetes or directly from the command line (rasa x) ?

Hi @fede ,

I am using the version that is installed from this command:

pip install rasa-x --extra-index-url https://pypi.rasa.com/simple

Then I am running Rasa X from the command line (rasa x).

Ok, could you try backing up your database file (rasa.db), then deleting rasa.db and trying again? That way we’re sure we are testing this on a completely new database.

Thank you, @fede.

Please let me get back later this afternoon, after 5. I’m at work, on a different project, and I can’t do it right now. Much appreciated.

Best, Titus.

Hello @fede!

I just wanted to let you know that Rasa X seems to be working OK, in spite of the warning, on my laptop. This weekend I’ll try to replicate what I’ve been doing on the laptop, on my PC, and I’ll get back.

Thank you for responding. Best, Titus.


Facing the same issue after I updated to Rasa X 0.28.5. And I have deleted the previous db’s, models everything and trained from scratch.

Thank you!

Same issue - i tried installing RasaX on ubuntu on AWS and on my macbook pro - used the one line install script. Both installations had the same issue - the bot receives the message - the intents are displayed - but then no response. I do see a response only for the greeting and when it cannot understand.

I am having the same issue as well :((

Hi guys,

As a quick fix for this issue, you can uninstall Rasa X 0.28.5 and install Rasa X 0.28, its working for me with this version.

Hope it helps!

@murtuza-workruit when installed rasa x == 0.28.0 and run rasa x I got

Make sure to start Rasa X with valid data and valid domain and config files. Please, also check any warnings that popped up

I wonder if you faced the same message, how did you solve it?

Nop, I didn’t get this message. It was working for me. Try deleting the old model and db files and also update Rasa aswell to the latest if you haven’t.

1 Like

Hello all, I found this related topic, it may help you

I checked this issue rasa x with own data failing · Issue #3563 · RasaHQ/rasa · GitHub and it supposed to have this issue on windows and we should consider using Ubuntu instead!
Are you still having the same problem with Ubuntu!!

The root cause of my issue is not having the action server available. I have been started Rasax using the one line deploy script - and then connecting to the financial-demo repository on Github that i have forked.

Getting the action server going and communicating with the kubernetes cluster is not working even though no changes have been made.

Rasax works fine in local mode.

1 Like

Still not getting the actions to execute in Rasa X.

I think this has to do with how i am running the action server.

I used the one line deploy script. Then i set environment variables export ACTION_SERVER_IMAGE=rasa/financial-demo export ACTION_SERVER_TAG=latest

I reran the one line deploy script.

Can someone please let me know how to fix the steps to get to executing actions in Rasa-X UI? thanks