'IntegrityError', My bot on Rasa X doesn't respond

I am using Rasa X locally, I installed it using: pip install rasa-x --extra-index-url https://pypi.rasa.com/simple and when I write, it recognizes the intent but doesn’t respond and I got this message:

**"WARNING:rasax.community.services.event_consumers.event_consumer:Saving event failed due to an 'IntegrityError'. This means that the event is already stored in the database. The event data was '{"sender_id": "604947a487904776b1538c8dc363f10e", "event": "action", "timestamp": 1591326887.867574, "name": "action_listen", "policy": null, "confidence": null}'. (sqlite3.IntegrityError) UNIQUE constraint failed: conversation_event.conversation_id, conversation_event.timestamp, conversation_event.type_name**
**[SQL: INSERT INTO conversation_event (conversation_id, type_name, timestamp, intent_name, action_name, slot_name, slot_value, policy, is_flagged, data, evaluation, rasa_environment) VALUES (?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?, ?)]**
**[parameters: ('604947a487904776b1538c8dc363f10e', 'action', 1591326887.867574, None, 'action_listen', None, None, None, 0, '{"sender_id": "604947a487904776b1538c8dc363f10e", "event": "action", "timestamp": 1591326887.867574, "name": "action_listen", "policy": null, "confidence": null}', None, 'production')]**
**(Background on this error at: http://sqlalche.me/e/gkpj)"**

update:
here’s the conversation


it should respond after this but action_listen is activated!
and here what I got after writing to the chatbot on the command:

I deleted rasa.db and events.db and still getting the same error, I also created a new project and copied needed files and also I am getting the same error!
note: bot was working perfectly using rasa shell
any help, please?

Hm, seems for some reason the action_listen is getting duplicated and that can’t be saved into rasa x :thinking: what is the result of pip list | grep rasa?

Actually, I am using windows 10 and anaconda so I can’t make this command but I searched for an alternative of grep and here are screenshots

I have another question please, when I was searching on the community I found that topic that may be similar to my issue Could not save event of type 'action' with timestamp and there’s a reply that says it’s an issue on windows 10, so is this my problem? using Rasa X on windows 10? @erohmensing

@erohmensing Hello Ella, I updated the topic with some screenshots after running again. kindly check them.

Interesting, does seem like that is the issue. Follow that thread there, I will check to see the status of the issue.

Were you able to find the solution, i have the same issue with rasa 1.10 and Rasa x 0.32