Rasa X - Talk to you bot not working

Version: Rasa X 0.32.2

I installed Rasa X on a GCP VM engine following the rasa tutorial on docker-compose.

Then I connected it to my GitHub repository where I have my chat bot files.

Then I uploaded the model from my local computer and I tried Talk to your bot but nothing is happenning.

I don’t know what could be wrong, I don’t knwo what to do to solve this issue.

Any idea ? thanks

Kindly check the version of Rasa X that got installed. The same problem happened with me when I mistakenly installed Rasa X 0.33 rc2 instead of rasa X 0.22.

Thanks for you ranswer, I installed the one suggested by defaut on this page:

which is 0.32.2.

You rather suggest to use the 0.22 version ?

I tried everything again. Instead of uploading the model, I trained it from Rasa X but the training failed as you can see on the picture below.

(Note that the taining succeded on my local computer and everything is working fine locally.)

Then I uploaded the model and I am again facing the same issue as above…

Sorry, it was a typo. I meant to write 0.32 instead of 0.22 Is your training data is in Rasa OS 2.0 format? If so, it is incompatible with Rasa 0.32.x. Rasa X 0.33.0 (compatible with 2.0) will be released in a few days.

1 Like

I’m not sure I have understood your question. My chatbot is developpeed with Rasa 1.10.14:

Rasa 1.10.14

which is compatible with Rasa X 32.x

I am also using rasa_sdk==2.0.0. For instance I have not connected the rasa action server, so this should not be the origin of the problem.

Anyway, thanks for your answer. I you have any idea to solve my issue, tell me !

You can verify what versions you are running with:

rasa --version

You might want to run this in both environments and ensure you are using the same version in both, as a “sanity check.”

At the bottom of credentials.yml do you have the “rasa” one defined? That is the channel used by RasaX when you are using the “Talk with your bot” feature.

Mine was the default and looks like this:

# This entry is needed if you are using Rasa X. The entry represents credentials
# for the Rasa X "channel", i.e. Talk to your bot and Share with guest testers.
  url: "http://localhost:5002/api"

You also want to make sure in RasaX that your model is shown as “Active” on the models screen, and not just uploaded.

As far as why your training data will not train on your server versus locally – you may have to dig into the logs generated on your server to see what training errors are happening.

Not a ton to go on, but hopefully something generates a lead for you!

Hi Chris, thanks for your answer.

  • Versions

Locallcy, I’m using Rasa 1.10.14

On the Google Platform VM, rasa is a command not found. May bo I skipped a step but I cann’t identify which one. As far as I have understood I don’t have any thing more to install after the step

sudo docker-compose up -d.

However, I noticed that in .env file is precised : RASA_VERSION=1.10.10

  • Credentials

credentials.yml is included in the docker image I pull when I execute docker-compose and I left the default file in which there is:


url: ${RASA_X_HOST}/api

which is normal because `RASA_X_HOST: “http://rasa-x:5002

  • Models I’m still not able to train from Rasa X.

Yes, the one I uploaded have been turned active for sure, otherwise it is even not possible to try the model. In my case I can try it but when I start talking, nothing happen.

  • Logs

Finally, the logs folder is empty…

I keep digging, thanks

Okay, I think I know where the issue is from : it is because I’m using french corpus with spacy.

Locally it’s working because I downloaded fr_core_news_md with the followin commands:

python -m spacy download fr_core_news_md

python -m spacy link fr_core_news_md fr

The problem now is that this two commands are not included in the default docker images I pull from rasa…

Does someone knwo how I could customize that ?

Perhaps you’ve found your answer by now – but you can take the Rasa base image, modify it, and then use that new image in your deployment.

Here’s a starter on how to commit changes to a docker image, there may be a rasa-specific version out there too:

1 Like