Rasa X | Set your Admin Password fails - "sudo: docker-compose: command not found"

I have followed the instructions as per the Rasa X - Quick Installation and successfully started Rasa X using docker on CentOS. However, when setting the admin password using below command:

sudo python rasa_x_commands.py create --update admin me PASSWORD

I get an error message that docker-compose: command not found

Any ideas how to resolve this issue?

I have gone through the rasa_x_commands.py and see that it was building below command. When i executed that it worked fine.

docker-compose exec rasa-x bash -c "python3 /app/scripts/manage_users.py create me welcome123 admin --update"

I added --update at the end because it gave me below error message without --update:

User ‘me’ already exists. You can update the password by running sudo python rasa_x_commands.py create --update me admin <new_pw>

1 Like

docker-compose exec rasa-x bash -c “python3 /app/scripts/manage_users.py create admin <new_pw> admin --update”. worked for me

From the terminal screenshot, you are already the root. So no need to use sudo here.