Rasa x server won't stop or connect to rasa open source


when i run “rasactl status” it shows that its running, but when i try to access it from a browser, says unable to connect.

Also every time i try to run the following commands, rasactl stop or rasactl connect rasa, it outputs this error Get “http://ip of localhost/api/version”: read tcp localhost:port->localhost:different port: read: connection reset by peer.

Thanks in advance.

Hey @raven99p. Are you running Rasa X on GCP by any chance? If yes, you might need to open up the port that Rasa X is running on. To do that:

  1. Go to cloud.google.com
  2. Go to my Console
  3. Choose your Project
  4. Choose Networking > VPC network
  5. Choose “Firewall”
  6. Choose “Create Firewall Rule”
  7. Choose a tag in Target Tags window: “https-server”
  8. IP ranges: ""
  9. TCP: your Rasa X port number or choose an option to allow all protocols and ports

Once the rule is updated, you should be able to connect to your Rasa X using the provided URL

1 Like


thank you for the response,

I’m actually running Rasa X on Digital Ocean, but I’ll try to check if the port if open.

1 Like


my vm uses iptables, and i tried adding a rule to allow all traffic to my port but to no avail…

Docker has created a few rules, but I’m not sure if they affect the port.

Hey @raven99p. This is very strange. I tested the installation on two different droplets and it worked both times. I didn’t do any customizations so I think my guess is that it has something to do with the iptables. Do you have any rules that block traffic or anything else that adds networking limitations?