Rasa X server deployment keeps loading

Hey there, I am trying to deploy Rasa X on a server with CentOS 7 and 8 GB RAM. I am using curl -s get-rasa-x.rasa.com | sudo bash which installs the embedded Kubernetes cluster and the Helm command line interface. Afterwards it says “Welcome to Rasa X” and gives me the passwords. Then there is “Deploying Rasa X…:” but it does not go further. Error-Message below. I tried deinstalling and reinstalling it multiple times but it does not work. Any ideas?


Are you still experiencing the issue? If yes, you can check pods with CrashLoopBackOff status in order to get more details on what’s wrong with your deployment.

Commands that you can use, e.g.:

kubectl describe pod <pod_name>
kubectl logs <pod_name>

Hi, yes I still have this issue. It says Lifeness probe failed, the tcp connection was refused. And there is a warning according to DNSConfigForming, because my resolv.conf contains more than 3 entries for search. I am in a managed network, but there should not be any problem with the port, it tries to connect to. May be a routing problem?

Afterwards I tried to deploy Rasa X with the docker compose deployment, which does not work either. The same containers are not running. Here it says Illegal instruction (core dumped).

I don’t know if this is a problem with CentOS 7 or because of the restrictions of the network. But both methods work on a Ubuntu 18.04 Server on GCP.

Do you have SELinux enabled (or do you use any other additional security policies) on CentOS7? I’d check dmesg and SELinux logs if there is any additional information.

Yes SELinux is enabled, but I dont get any addition information