RASA X running Error: Make sure to start Rasa X with valid data and valid domain and config files

@nik202 sorry i didnโ€™t noticed that you asked me to mention you . thanks a lot for helping ") have a good day

it worked thanks again @nik202 :heartpulse:

@sloka Its ok. Happy Coding. Good Luck!

@nik202 i got an other error, the ui works fine but the bot doesnโ€™t give a response

@sloka if it is related to this, go ahead else please create other thread.

@nik202 Hello, iโ€™ve downgraded the Rasa X Version to 0.39.3, but it still display โ€œMake sure to start Rasa X with valid data and valid domainโ€ฆโ€ message.

@AhChing11 Hello, Please install for RowProxy Error

pip install SQLAlchemy==1.3.22

@nik202 It shows another error :โ€™)

@AhChing11 No worries. Please delete the events and rasa .db file from project folder and run again rasa x. This time it will work for you. Good Luck!

1 Like

It shows this error AttributeError: 'Sanic' object has no attribute 'auth'. Then based on this thread, AttributeError: 'Sanic' object has no attribute 'auth' - #43 by nik202, I just installed sanic-jwt==1.6.0, run rasa x again, and it is now working already. Thanks a lot nik. By the way, below is the error, my rasa version, and the code I use to install sani-jwt hope it can help other people too.

@AhChing11 You issue is solved Ching?

Yeap, Rasa X is working, the tab opened in my browser. Thanks a lot.

@AhChing11 Cool. Enjoy Rasa !!

1 Like