Rasa X installing issues in every way possible

cant install rasa X been facing this issue from the time i tried to install rasa x. tried different python version and couldn’t even download rasa. can not uninstall ‘ruamel-yaml’ manually or install rasa x ignoring ‘ruamel-yaml’.

Hi and welcome @Navaneetdatta

Try this: Rasa X runs with several Errors & Warnings - #4 by nik202

OR

If not, start with the fresh process.

Please follow these steps for the installation of ROS and Rasa X :slight_smile:

Note: You can ignore few steps, if you already performed it!

Please install Anaconda from Anaconda | Individual Edition , then create the conda environment using the following command

  1. conda create -n rasa3 python=3.8
  2. conda activate rasa 3

PS: If you using Linux, check the environment for the same.

Note: I’d recommend to create a fresh environment if not you can proceed with the next steps:

Note: If you are not able to install you can downgrade the pip version to 20.2

For Rasa Open Source:

`pip install rasa==2.8.1`
`pip install rasa-sdk==2.8.1'

check version rasa --version its install or not

For Installing basic project:

rasa init

then if you need

For Rasa-X Installation

pip install rasa-x==0.39.3 --extra-index-url https://pypi.rasa.com/simple

check rasa version rasa --version its install or not

You will see some error : ImportError: cannot import name ‘RowProxy’ from ‘sqlalchemy.engine’ Install

pip install SQLAlchemy==1.3.22 should fix it

If sanic related error: pip install sanic-jwt==1.6.0

delete .db (events and rasa ) if is showing alembic issue.

If you have any errors in-between please share with us.

Note: You will see the Event Loop Close error in the terminal, you can ignore that, its is a persistent issue with Rasa X, and the team is working on it.

I hope this will solve your issue. Good Luck!

@Navaneetdatta If you only need ROS, so please don’t install rasa x ok ? and if you are required please go ahead.

If you were able to solve this please do close this thread while marking the solution tick next to this thread.

This is the error am facing.

@Navaneetdatta Confirm me few things and yes I’m aware of this error :

  1. Are the Anaconda Install? did you follow any video for that?
  2. Did you followed all the above steps? Yes Or No
  3. What is your rasa --version right now?

Solution: Please see this thread fro C++ Build Issue. Windows installtion of Rasa x - #5

Yes Anaconda is installed. I followed the exact steps. These are the versions Rasa Version : 2.8.1 Minimum Compatible Version: 2.8.0 Rasa SDK Version : 2.8.1 Rasa X Version : None Python Version : 3.8.12 Operating System : Windows-10-10.0.22000-SP0

@Navaneetdatta Did you tried this? Solution: Please see this thread fro C++ Build Issue. Windows installtion of Rasa x - #5

Same error even after reinstalling anaconda and creating a new env and installing everything in suggested versions.

@Navaneetdatta share me rasa --version while activating your environment?

hey is there any possibility for you to hop on a call and i can share my screen. if its okay if its not possible thts totally fine. i am not sure what am doing wrong.