Rasa X Fails to train/upload model


I am getting the following error when trying to train a model in Rasa X. The deployment is on kubernetes in AWS, has anyone seen this before and could help ? Could this be to do with the memory on rasa-production or rasa-worker , we have the amounts given in Helm Chart Installation

{version: “0.38.1”, status: “failure”, message: “Failed to train a Rasa model.”,…}

code: 500

details: “Cannot connect to host rasa-x-1619477442-rasa-worker.ai-inv.svc:5005 ssl:default [Connection refused]”

help: null

message: “Failed to train a Rasa model.”

reason: “StackTrainingFailed”

status: “failure”

version: “0.38.1”

Are all of your pods running? It looks like Rasa X is not able to connect to your rasa worker pod.

Hi Ella,

Yes all pods were running before I tried to run the training, it looks like it crashes when I try and do that.

This has now been solved, some of the values added in the values.yml file were incorrect.

Which values? I am having the same problem.