Rasa X deployed on google cloud engine model not training

I have deployed rasa x onto google cloud platform, (Following rasa master class episode 9) I have linked github also, and all the training data is available as well.

But when I train the model, it dosn’t do anything.( no models come up)

I tried uploading a pre trained model from my local environment.But it dosn’t respond.

This is my github repo

I have also added a docker-compose.override.yml

version: '3.4'
    image: 'rasa/rasa-sdk:latest'
      - './actions:/app/actions'
      - '5055'
      - rasa-production

Could it be any issues in the file ?? :thinking:

The rasa x is up, but I can’t find any models to talk to. Uploaded model dosn’t respond too.

Please help.

Have you tried using the one-line-deploy on your GCP instance instead?

Then integrate your local model with Integrated Version Control – Connect a git repository. You should be able to train your model on Rasa X or enable your model in Rasa X if you trained it locally before uploading to Git.

Hi @_sanjay_r

I was getting the same problem, but I had to confirm changes on my repository from the menu of RASA X select confirm changes and that’s it.