Rasa-X Linking to Action server not working

Hi all, I have been able to successfully installed Rasa-X using one line deploy command described here.

I have also being able to connect Rasa-X to github and Rasa-X correctly fetch data in its UI.

However I’m not able to make a conversation with bot. I think this is due to the Action server which is not properly set.

I follow the doc here that describes to add a variable ACTION_SERVER_IMAGE and ACTION_SERVER_TAG.

The problem is that, my ACTION SERVER is PRIVATE. So how can I set credentials in this case to correctly pull the image.

PS: We are using Amazon container Registry(ECR) to store our private image. Any Hint @erohmensing @amn41 ?

Thanks in advance for your response.

hi @Rogers_ntr ! Very cool that you’re up and running with a git connection! Any trouble with the deployment process?

Yes, if you want to use a private docker image, please create a secret that can access your ECR, and then do:

helm upgrade rasax  rasa/rasa-x  --reuse-values  --set images.imagePullSecrets[0]=secretName

Hi @amn41 Thanks for the reply. The deployment is stuck with the issue that I just raise. Apart from that, everything works.

When I try to run what you said, I get this error. Error: failed to download "rasa/rasa-x"

I tried to run this helm repo update, but it doesn’t help that much.

Any hint is welcome.

Hey @Rogers_ntr! There was a typo in Alan’s response, and here is the right way of upgrading your Helm chart:

helm upgrade <your release name> rasa-x/rasa-x --reuse-values --set images.imagePullSecrets[0]=<secretName>

@alwx, Thanks for the response. What is the release name please ?

Should be just rasax, but you can execute helm ls to check it.

Thanks @alwx . I tried it and her is the response that I get:

Error: UPGRADE FAILED: "rasax" has no deployed releases

Any clue ?

What’s the output of helm ls?

@alwx It didn’t output anything. Quiet suprising!

Can you try this?

helm ls --namespace rasa

And, if it works:

helm upgrade rasax rasa-x/rasa-x --namespace rasa --reuse-values --set images.imagePullSecrets[0]=<secretName>

@alwx I get this error after retrying with rasa as deployment name. The full command:

helm upgrade rasa rasa-x/rasa-x --namespace rasa --reuse-values --set images.imagePullSecrets[0]=<secret_name>

But I got this new error:

Error: UPGRADE FAILED: error validating "": error validating data: ValidationError(Deployment.spec.template.spec.imagePullSecrets[0]): invalid type for io.k8s.api.core.v1.LocalObjectReference: got "string", expected "map"

However this command bellow works:

helm ls --namespace rasa

and its output is:

rasa rasa 17 2020-05-13 08:12:17.840153216 +0000 UTC deployed rasa-x-1.2.7 0.27.4

Any hint ?

Hi, Solution is to use this:

helm upgrade rasa rasa-x/rasa-x --namespace rasa --reuse-values --set images.imagePullSecrets[0].name=<secret_name>
1 Like