Cannot build new image for action server

Hi everyone,

recently I have tried to build a new action server image without any success. I am running my chatbot via Docker on a server with ubuntu 18.04 and the following rasa specifications:


For the installation I did the following steps:

  1. To install the script on my server I followed this [Installation Guide] to set up Rasa X on the server with docker.

  2. The Integrated Version [Connect Rasa Open Source to Rasa Enterprise] also works well.

  3. Then I tried to create a new custom action server with an action server image as followed:

3.1 create a "docker-compose.override.yml inside /etc/rasa Here is the content of this file:

version: '3.4'
     image: 'rasa/rasa-sdk:1.10.3'
       - './actions:/app/actions'
       - '5055'
       - rasa-production

3.2 After that I created a so called Dockerfile:

# Extend the official Rasa SDK image
FROM rasa/rasa-sdk:1.10.3

# Use subdirectory as working directory

# Copy any additional custom requirements, if necessary (uncomment next line)
COPY actions/requirements-actions.txt ./

# Change back to root user to install dependencies
USER root

# Install extra requirements for actions code, if necessary (uncomment next line)
RUN pip install -r requirements-actions.txt

# Copy actions folder to working directory
COPY ./actions /app/actions

# By best practices, don't run the code with root user
USER 1000

3.3 In the next step I built the action server image manually. First of all, I generated the directory /etc/rasa/actions and created the following files:

  • _ init

I copied and pasted my actioncode into the and added the dependencies into my as followed:

mysql-connector-python == 8.0.21
requests == 2.24.0
  1. Now I brought my containers down: docker-compose down

  2. Afterwards I tried to build the image without success:

Does anyone have any recommandations how to handle this issue? I want to run mysql-connector-pyhton to have access to my private database.