RASA X - Integrated Version Control Invalid Project Layout


For some reason when I try to attach the Integrated Version Control, using RASA X on a Google Cloud Engine, I get this UserWarning:

UserWarning: The connected repository has an innvalid project layout. Integrated Version Control requires the domain to be present at the following path: 'domain.yml'

Also on RASA X itself I get the following message:

Something went wrong. Please try again.

I triple checked my structure and everything but it is completely fine, so I am confused why I am getting this error.

Furthermore, my SSH key is actually used by RASA x as I am able to see this in Github.

Some help would be nice, thank you :)!

@SamS can you inform someone for me about this as well? My project layout can be found below:

I thank you in advance and wish you a nice weekend!

1 Like

Not a solution to this, but pushing the same code to a new branch worked for me.

You received the same error as well and did you give your new branch a specific name? However, I am guessing that does not matter necessarily. I will try this and see if it works.

EDIT: I tried it but it still does not work…

I’m also facing same issues while deploying chatbot through integrated version control. Please help me to resolve this issue. @Juste @amn41 @rctatman @juste_petr @erohmensing @Tobias_Wochinger @alexweidauer @Emma

1 Like

@SamS could you guide someone to this post as well? I really need help on this :slight_smile:. Thanks in advance.

@LAKSHMI25NPATHI did you resolve this issue yet? I haven’t figured it out…

@fabrice-toussaint No, I tried but getting same errors. Once I get know will inform you.Thanks.

1 Like

Hi @fabrice-toussaint, what Rasa X version are you using?

1 Like

Hi, curl -sSL -o install.sh https://storage.googleapis.com/rasa-x-releases/0.33.0/install.sh

Rasa x version is 0.33.0.

@fede I am using the docker-compose tutorial:


and my version is 0.33.0.

@LAKSHMI25NPATHI is it resolved for you already now? :stuck_out_tongue:

No, I’m waiting for reply from RASA team.

@fede can you help me? I am still receiving the error… :slight_smile:

@LAKSHMI25NPATHI did you manage to fix it already…? :stuck_out_tongue:

No, now I’m not working on that. After some days I will restart it. I hope before that RASA team may respond. At least one of RASA support team should respond for this query. We were waiting long for response from RASA team. But, they are not responding us.

1 Like

Can anybody help us with this issue, it is still occurring. Both through the docker-compose setup and kubernetes setup.

@Juste @amn41 @rctatman @juste_petr @erohmensing @Tobias_Wochinger @alexweidauer @Emma @stephens


Solution for me was to initialize rasa (rasa init) in the master branch.