Rasa X failed to run

Hi I tried to run my rasa x after I left it for some while (2 weeks maybe?). and I’m getting these error when I ran Rasa X command. If I ran rasa shell the bot is loaded. This is the error log when I ran rasa x --debug.

  File "c:\users\administrator\anaconda3\lib\runpy.py", line 193, in _run_module_as_main
"__main__", mod_spec)
File "c:\users\administrator\anaconda3\lib\runpy.py", line 85, in _run_code
exec(code, run_globals)
File "C:\EDARAN_FAQ_CHATBOT\envEdaran\Scripts\rasa.exe\__main__.py", line 7, in 
File "c:\edaran_faq_chatbot\envedaran\lib\site-packages\rasa\__main__.py", line 92, in 
File "c:\edaran_faq_chatbot\envedaran\lib\site-packages\rasa\cli\x.py", line 326, in rasa_x
File "c:\edaran_faq_chatbot\envedaran\lib\site-packages\rasa\cli\x.py", line 414, in 
from rasax.community import local  # pytype: disable=import-error
File "c:\edaran_faq_chatbot\envedaran\lib\site-packages\rasax\community\local.py", line 9, 
in <module>
import rasax.community.initialise as initialise
File "c:\edaran_faq_chatbot\envedaran\lib\site-packages\rasax\community\initialise.py", 
line 19, in <module>
from rasax.community.services.user_service import UserService
File "c:\edaran_faq_chatbot\envedaran\lib\site- 
packages\rasax\community\services\user_service.py", line 13, in <module>
from rasax.community.database.admin import User, Role, SingleUseToken
File "c:\edaran_faq_chatbot\envedaran\lib\site- 
packages\rasax\community\database\__init__.py", line 8, in <module>
from rasax.community.database.admin import (
File "c:\edaran_faq_chatbot\envedaran\lib\site- 
packages\rasax\community\database\admin.py", line 7, in <module>
from rasax.community.database import utils
File "c:\edaran_faq_chatbot\envedaran\lib\site- 
packages\rasax\community\database\utils.py", line 6, in <module>
from sqlite3 import Connection as SQLite3Connection
File "c:\users\administrator\anaconda3\lib\sqlite3\__init__.py", line 23, in <module>
from sqlite3.dbapi2 import *
File "c:\users\administrator\anaconda3\lib\sqlite3\dbapi2.py", line 27, in <module>
from _sqlite3 import *
ImportError: DLL load failed: The specified module could not be found.

Thanks for the help!

Hi @acapothman, it could be related to an issue others have encountered with SQLite in Anaconda: windows - Unable to import sqlite3 using Anaconda Python - Stack Overflow

Thank you!