"EOFError: Ran out of input" when try to run "rasa x"

hi everyone . I have installed rasa x. rasa shell working fine. I can chat within terminal . but when I try to run rasa x I getting some error. How can I solve this?

(rasa) E:\tutorial\chatbot\chtbot development\Rasa chatbot>rasa x
Starting Rasa X in local mode... 🚀
Traceback (most recent call last):
  File "c:\programdata\anaconda3\envs\rasa\lib\site-packages\rasa\cli\x.py", line 431, in run_locally
    args, project_path, args.data, token=rasa_x_token, config_path=config_path
  File "c:\programdata\anaconda3\envs\rasa\lib\site-packages\rasax\community\local.py", line 186, in main
    app = rasa_x_server.configure_app()
  File "c:\programdata\anaconda3\envs\rasa\lib\site-packages\rasax\community\api\app.py", line 206, in configure_app
    app.blueprint(interface.blueprint())
  File "c:\programdata\anaconda3\envs\rasa\lib\site-packages\rasax\community\api\blueprints\interface.py", line 119, in blueprint
    interface_directory = locate_interface()
  File "c:\programdata\anaconda3\envs\rasa\lib\site-packages\rasax\community\api\blueprints\interface.py", line 104, in locate_interface
    return build_interface()
  File "c:\programdata\anaconda3\envs\rasa\lib\site-packages\rasax\community\api\blueprints\interface.py", line 80, in build_interface
    p.start()
  File "c:\programdata\anaconda3\envs\rasa\lib\multiprocessing\process.py", line 105, in start
    self._popen = self._Popen(self)
  File "c:\programdata\anaconda3\envs\rasa\lib\multiprocessing\context.py", line 223, in _Popen
    return _default_context.get_context().Process._Popen(process_obj)
  File "c:\programdata\anaconda3\envs\rasa\lib\multiprocessing\context.py", line 322, in _Popen
    return Popen(process_obj)
  File "c:\programdata\anaconda3\envs\rasa\lib\multiprocessing\popen_spawn_win32.py", line 65, in __init__
    reduction.dump(process_obj, to_child)
  File "c:\programdata\anaconda3\envs\rasa\lib\multiprocessing\reduction.py", line 60, in dump
    ForkingPickler(file, protocol).dump(obj)
AttributeError: Can't pickle local object 'build_interface.<locals>.run_build'

Sorry, something went wrong (see error above). Make sure to start Rasa X with valid data and valid domain and config files. Please, also check any warnings that popped up.
If you need help fixing the issue visit our forum: https://forum.rasa.com/.
Traceback (most recent call last):
  File "<string>", line 1, in <module>
  File "c:\programdata\anaconda3\envs\rasa\lib\multiprocessing\spawn.py", line 105, in spawn_main
    exitcode = _main(fd)
  File "c:\programdata\anaconda3\envs\rasa\lib\multiprocessing\spawn.py", line 115, in _main
    self = reduction.pickle.load(from_parent)
EOFError: Ran out of input

To run Rasa X on Windows 10, it is recommended to use docker.

See the Rasa X documentation on Docker Compose Manual Install

@Arjaan thank you. My problem solved. I installed rasa x version 0.27.2 . Now it works fine in my computer.

@shoeb-howlader,

that is great news. Thank you for the update.

Are you using the docker-compose installation?

1 Like

@Arjaan . I am using local mode .