Rasa x " Failed to install frontend dependencies. Check logs for details. "

I installed rasa and rasa x and I got no error during installation. When I run rasa train and rasa shell , I have no errors which works fine. When I execute rasa x then I’m getting the below error. I using below config:

rasa 1.9.3
rasa-sdk 1.9.0
rasa-x 0.27.1

Also, a new browser window was opened and showing me this cat image.

How to solve this issue? Thank you.

I am also facing the same issue, seems like its a bug in rasa x

same error

Hey! This problem was introduced because of changes we made in how we manage Rasa X’s dependencies. It will be fixed with the 0.27.2 release which should be out shortly.

Edit: 0.27.2 has been released! Please update your Rasa X version.


Thanks @fede for updating:

Here comes the latest version of Rasa x just update your Rasa x with below command: I tested it, its working fine. Just update it

pip install rasa-x==0.27.2 --extra-index-url https://pypi.rasa.com/simple

Activate virtual environment before running this code.

Note Configuration:

Rasa - 1.9.3
Rasa SDK - 1.9.0
Rasa x - 0.27.2

Don’t install Rasa X versions(0.27.0 & 0.27.1) dependencies are not supported.

Its working now, thanks :slight_smile: