Installation of Rasa and Rasa x on ubuntu

I have created one tutorial on how to install Rasa and Rasa X on the Linux machine in regional language(Hindi). Link: YouTube

2 Likes

@sagarvanave thank you. you video showed basic start up

On following your video lecture…I am getting this error for installing Rasa-X on my Ubuntu Laptop. Pl. guide me Sir

On the localhost url I keep getting the error “Frontend compiling…and now…we wait”

Solution- Rasa X latest version (0.27.1) has bug, so just follow the steps below to make Rasa X work-

  1. Uninstall “rasa”, “rasa-sdk”, & “rasa-x” (if you have it installed)

  2. Install Rasa X 0.26.3 by this command-

    pip install rasa-x==0.26.3 --extra-index-url https://pypi.rasa.com/simple

    (automatically this will install the compatible rasa version & make sure to use pip / pip3 as per your default python)

  3. create a demo bot by “rasa init”

  4. type “rasa x”

1 Like

I also tried but there is some problem with the latest version of rasa x. So you can use older version :slightly_smiling_face:

can u please help i want to install rasa and rasax but iam getting error.

i executed the following codes

1.pip install rasa-x --extra-index-url https://pypi.rasa.com/simple 2.pip install rasa[spacy] 3.python -m spacy download en_core_web_md 4.python -m spacy link en_core_web_md en

2,3,4 no problem in execution.but the first i am getting the following error.

yeah i’m also getting same error in new version…

me too I try to install on ubuntu 20.04 and get the same error

actually I fixed this problem… I’m also facing this issue at that time… and then I realized the problem… if you use pycharm, 1st step is project creation and screen shows like this…!! the python interpreter is the main thing of this issue… just change the python interpreter conda to virtualenv from that list…!

conda to virtualenv

don’t use the conda interpreter! And then create the project, start the rasa installation. it will be installed without any issue.

Thank You :wink: