Front end error while trying to start rasa x

While trying to run rasa x on latest version 0.27, it cant start the interface and instead some cat pics. any help :frowning: Here are my log

Building frontend (development mode)...
make: *** No rule to make target 'install-frontend'.  Stop.
Failed to install frontend dependencies. Check logs for details.
Process Process-2:
Traceback (most recent call last):
  File "/usr/lib/python3.6/multiprocessing/process.py", line 258, in _bootstrap
self.run()
  File "/usr/lib/python3.6/multiprocessing/process.py", line 93, in run
self._target(*self._args, **self._kwargs)
  File "/usr/local/lib/python3.6/dist-packages/rasax/community/api/blueprints/interface.py", line 65, in run_build
"Frontend install failed! Check the logs for details.",
  File "/usr/local/lib/python3.6/dist-packages/rasax/community/api/blueprints/interface.py", line 37, in _write_index_html
os.mkdir(path)
FileNotFoundError: [Errno 2] No such file or directory: '/usr/local/lib/python3.6/dist-packages/rasax/community/api/blueprints/../../../../../../src/frontend/build'

I also tried to install earlier version of rasa x using

python3 -m pip install -U rasa-x --extra-index-url https://pypi.rasa.com/api/package/rasa-x/rasa-x-0.26.3.tar.gz

but it’s seem lie pip trying to clollect

Collecting rasa-x Downloading rasa-x-0.0.2.tar.gz (1.4 kB) instead

Try pip install -U rasa-x==0.26.3 --extra-index-url https://pypi.rasa.com/simple instead.

To your first question, I think there was some problem, but it is resolved now (at least it works when I installed it just now)

I am also facing similar issue, tried this python3 -m pip install -U rasa-x --extra-index-url [https://pypi.rasa.com/api/package/rasa-x/rasa-x-0.26.3.tar.gz as well but not working

I’m facing the same issue here. Last time a cat image showed up on my browser with words: Frontend compiling - and now… we wait. After waiting for a few hours, I tried to reinstall ubuntu. But that seems not help much.

Hi @mloubser, rasa x 0.26.3 when installed getting error message " rasa x 0.26.3 is outdated " and what @vova999 says in the question is the exact error I too getting with cats images for both 0.27.0 and 0.27.1 versions. Exactly whats causing error?

Hi @vova999, @Akshay179, @lotuong, if you find solution please post it. Thank you.

For now I downloaded 0.26.0 version of rasa and install it locally by pip install <path> you can download the .tar.gz here: package index

@vova999 is it worked ?

not for me

Yes, it works just uninstall 0.27.x version and re-install 0.26 version locally

What is your Rasa version?

i installed0.26 version of rasa -x now getting below error

You are using an outdated version of Rasa X (0.26.0). A new version 0.27.1) is available. Please follow these instructions to update:

Starting Rasa X in local mode… :rocket: Traceback (most recent call last): File “/Users/akshayarora/rasachatbot/lib/python3.7/site-packages/alembic/script/base.py”, line 158, in _catch_revision_errors yield File “/Users/akshayarora/rasachatbot/lib/python3.7/site-packages/alembic/script/base.py”, line 360, in upgrade_revs revs = list(revs) File “/Users/akshayarora/rasachatbot/lib/python3.7/site-packages/alembic/script/revision.py”, line 755, in iterate_revisions requested_lowers = self.get_revisions(lower) File “/Users/akshayarora/rasachatbot/lib/python3.7/site-packages/alembic/script/revision.py”, line 319, in get_revisions return sum([self.get_revisions(id_elem) for id_elem in id], ()) File “/Users/akshayarora/rasachatbot/lib/python3.7/site-packages/alembic/script/revision.py”, line 319, in return sum([self.get_revisions(id_elem) for id_elem in id], ()) File “/Users/akshayarora/rasachatbot/lib/python3.7/site-packages/alembic/script/revision.py”, line 324, in get_revisions for rev_id in resolved_id File “/Users/akshayarora/rasachatbot/lib/python3.7/site-packages/alembic/script/revision.py”, line 324, in for rev_id in resolved_id File “/Users/akshayarora/rasachatbot/lib/python3.7/site-packages/alembic/script/revision.py”, line 387, in _revision_for_ident resolved_id, alembic.script.revision.ResolutionError: No such revision or branch ‘73f46e0b7789’

The above exception was the direct cause of the following exception:

If it worked for anyone please post here

@ skjainmiah is it worked for you>

No, It’s not working for me.

We are not getting any help from community as well

Building frontend (development mode)… make: *** No rule to make target ‘install-frontend’. Stop.

Hi everyone, this is a reported issue, and a fix should be released in Rasa X 0.27.2. Thanks for your patience

Any idea when it will be released

@Akshay179 the issue is fixed in the new version release.

Yes able to work on it now