Rasa x display display issue


I am working on rasa x and i have some issues with the display. I have written a response like Please choose from the following options A B C But the issue is it will only show till Please select from the following and other options and will not show below that. Once i enter some options then it will display all options. I am doing talk to your bot option. Can anyone help me in this.

If you are working with Rasa X and not an external chat window, you can at first start to refresh the whole conversation. Also, you should double-check if you included the loaded options correctly. From where are this options loaded? Are they defined within your story and utterance? E.g. are they put into buttons?

Yes i am using rasa x “talk to your bot” option. From the refresh do you mean restart option? Also, you should double-check if you included the loaded options correctly- Could you please clarify this statement. These options are coming from story and nlu.md file. No we are not using any buttons.

Also how can i configure with any external chat window ?

Can you post screenshots to clarify what you mean, and also post the relevant domain file templates?

@erohmensing received this error when i tried to run the command.

@AnkitSingh21 according to the command, you should add --user to your command. Have you tried that? This seems like a separate issue from the original, though.

@erohmensing I ran the command using “Run as administrator” option and i did not receive the error. But still some errors are there.

@AnkitSingh21 those errors are fine. You are no longer using the rasa-core package, in fact you can uninstall it.

@erohmensing can you help me with the command please

I’m not sure what you’re trying to do, there’s no actual error there

I just tried to run the command provided by you to update rasa

pip install -U rasa-x --extra-index-url https://pypi.rasa.com/simple

Yes, and it’s working correctly. As I mentioned there errors you showed are irrelevant as you aren’t using rasa-core, so its requirements don’t matter. Are you running into other problems?

@erohmensing I am having issues with the display. Please check this post.