Rasa X dialog box not appearing

I am running Rasa X on my ec2 instance (Using Rasa 1.9.5). Though I’m able to access the Rasa X User Interface from my browser, I cannot find the dialog box to talk to the bot. I’ve attached the screenshot of the talk to the bot tab, you can see that the dialog interface is missing. I’m unable to find out what’s going wrong, any help would be much appreciated.

Hi Vaishnavi and welcome to the forum.

Can you open the browser debug window, go to the network tab and then browse the the chat window and let me know if you see errors?

You can also do a docker-compose logs rasa-x and report any errors you see there.

Also confirm that you have an active model in the Models screen.


Hi Stephens, I tried what you told and I do not see any errors on my network tab. I have an active model in my Models screen. Attaching you the screenshots. I am trying to run just basic intents which gets initialized when we run rasa init. I have not used docker for installing any of these.!!

Thank you so much for your time.

Hi, When I start conversing on my rasa cli (my rasa x is running in a different terminal) I notice rasa throwing up errors. If I do not have rasa x running rasa cli responds without any error. Attached are the screenshots of rasa throwing error:

@vaish1 Is there any reason you’re running Rasa X in local mode, rather than with the recommended deployment method? One-Line Deploy Script

Hi we have firewall issues for running ‘One line deploy script’

I have had the exact same issue and I have tried to do both local mode and deployed with docker-compose. I encounter the same situation. Here’s some screenshots from the console when I navigate to the talk to your bot screen that can hopefully add more information.

On the docker-compose side I’m getting

@vaish1 what kind of firewall issues - it can’t pull the script or it can’t pull the containers?

@smartexpert there seems to be an issue with authentication with the rabbit service. Did you set this up with our quick install docker-compose script? Did you make any customisations?

Yes I set it up with the quick install docker-compose script. Incidentally, I have another instance running on a separate VM that I setup with the docker-compose manual install instructions and the docker-compose logs for rabbbit show rabbit_1 | 2020-04-14 00:15:13.012 [info] <0.626.0> connection <0.626.0> ( -> user 'user' authenticated and granted access to vhost '/

I started fresh on a new VM with docker-compose quick install and all seems to be working fine with rasa production and worker version 1.9.5 and rasa x 0.27.5.

The only thing that is different is I haven’t configured a DNS name and am accessing via IP directly. Wonder if it was something related to how I would need to configure rasa x with a DNS name.

@smartexpert i doubt it’s anything to do with IP/DNS. I think something must have gotten messed up with your rabbit credentials on the other machine - not 100% sure what. Are you fine to use the fresh VM going forward?

Yes, I’m fine to use a new VM going forward but somewhat concerned if I’m not able to replicate the setup if we bring it down for maintenance of move things around.

Hello everyone,

Please please help !!! I can’t start with RASA X because I don’t have an international credit card and thus I can’t have an account on Google Cloud Platform. Can someone help me?

Thank you so much !!

Hi I could solve this issue. The problem was that my rasa shell server was running in the terminal so I could not see the dialog box on my UI. Once I stopped my rasa shell cli it worked fine. Thanks everyone.

1 Like