Rasa x connection to Github

Hello!I have problem with connecting rasa x to github repository.It stays in loading mode as in picture.I can’t connect and I can’t disconnect from repository.Until this time i had connection then i uploaded to github new code after that it stays as in picture.Help please!

I am having the same issue from yesterday. I am getting a yellow bar . It is not turning green. they are saying the git and server have differences. I have gone by the masterclass epi 9 reference and done all the setting accordingly. further it also states that I am connected to the github… . But for some reason it doenst update the data from my git to the rasa x and hence to my server .

@erohmensing could you please give me some hint as to why it is happening. Now my server has hung and I am stuck not able to enter in. That not connected bar is constantly loading god knows what!!

@MMustafa have you tried logging out and back in to see if it fixes the constantly loading error?

Yes I tried a lot I just press button “Disconnect” and after it disconnected

One more question what should I write instead of localhost here url: “http://localhost:5055/webhook

instead of localhost:5005, it should be the URL where you access your rasa x instance.

I run rasa x on server is it right if i write server_ip:5055?or server_ip:5005?

Agh i’m sorry, I thought you were referencing the /webhooks/channel/webhook – did not read that right. For the action server endpoint, that should be part of the deployment setup, you don’t have to configure it :slight_smile:

It’s taken care of here: https://github.com/RasaHQ/rasa-x-helm/blob/master/charts/rasa-x/templates/rasa-config-files-configmap.yaml#L38

Hello @erohmensing I have problem connecting to github.I did some changes in actions.py file so I turn off all docker containers and then turn on all of them but now it does not connect to guthub just stays in loading mode and instead of master there is written Not connected.Help please

@MMustafa can you try deleting the connected repositories and trying again?

Here you can list any connected repositories and you can use this endpoint to delete them.